Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Important Tip for users who are Upgrading

RaizeRaize vancouver ✭✭
edited September 2010 in Vanilla 2.0 - 2.8
Before you upload the new forum software, disable all your plugins. Trust me, this will save you a loootttt of headaches and stress. Just disable them, overwrite your forum software with the new files, and then go back and activate the plugins again one by one.

The problem is that once you upgrade, theres a 50/50 chance that some of the plugins may not work anymore... worse, they could break your forum and stop it from working. By using this method, you'll be able to proactively prevent this type of thing and at the same time you'll know which plugin breaks the forum. So if it's only 1 plugin that's causing the problem, you will know without having to stress.

Just fyi

Comments

  • with that said, shouldnt this be built into the upgrade process for automation ?
  • RaizeRaize vancouver ✭✭
    i guess it could be... but from my experience with wordpress automated upgrades never work
  • YMMV but I've been doing automatic upgrades regularly since WP 2.8.1 and I'm on the nightly build development track of WP. The only fails I have had have been because a plugin generated a fatal error on activation.
  • TimTim Operations Vanilla Staff
    with that said, shouldnt this be built into the upgrade process for automation ?
    We get it, you want an installer :p

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • its become the norm, and its good for addon/plugin/app developers. Opens the market up to a larger audience when users can easily install and uninstall, automatic updates, and removing the fear of a bonked install. not to mention its user friendly :)

  • RaizeRaize vancouver ✭✭
    edited September 2010
    Couldn't the noobs just use the .com hosted version of Vanilla? Why blur the line...
Sign In or Register to comment.