Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Running on localhost

edited December 2005 in Vanilla 1.0 Help
I'm sure you've all managed to get it running on localhost, but how?

Pretty sure I must have missed something, but I'm not sure what to change.

Getting errors like;
Warning: include(C:\Server\htdocs\fex\appg/../conf/settings.php) [function.include]: failed to open stream: No such file or directory in C:\Server\htdocs\fex\appg\settings.php on line 199

Comments

  • Options
    Obviously it has something to do with forward vs. backward slashes. Not sure if that's your fault or vanilla's but open up appg/settings.php and change any paths to use backward slashes.
  • Options
    On the contrary, it looks to me like the problem is that he's using backslashes, which are being mixed with forward slashes in the include path and causing difficulty. I've always used forward slashes in PHP and they've worked fine with Windows.
  • Options
    I only suggested backward slashes because PHP referenced the file in error with backward slashes. However, aanand's comments do make sense, so change them all to forward slashes and see what happens.
  • Options
    Did you rename conf/settings-dist.php to settings.php yet?
  • Options
    SirNot, no I hadn't. I'm not entirely sure what the conf directory is for. However I've edited what's in there.

    Removed all the errors that are coming up, now when trying to login I get this bug;

    A fatal, non-recoverable error has occurred Technical information (for support personel): Error Message An error occurred while validating your credentials. Affected Elements UserManager.ValidateUserCredentials();

    I believe the details should have been Admin/admin which I used to login.
  • Options
    Is this 9.3? You need to do what SirNot said, and the login would be Admin, pwd=Admin, case sensitive. The Admin user is only there if you used vanilla.sql.
This discussion has been closed.