Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Initial install - Error-403

edited October 2010 in Vanilla 2.0 - 2.8
I've just tried to install Vanilla forums. I currently have bbPress running, but i wanted to compare them side by side. On my server i have a bbPress folder and now the Vanilla-Garden-822518 folder.

I created a new database, but when i got to i get "Error 403 - Forbidden
You tried to access a document for which you don't have privileges."

I tried renaming the folder to just "Vanillaforums" but got the same error.

What should i do? I'm assuming it's possible to have 2 separate forums running on the same server as long as it's separate folders/databases.



  • Options
    TimTim Operations Vanilla Staff
    This sounds like a filesystem problem. At the linux command line, give 755 permissions to vanillaforums/ like this:
    chmod 755 vanillaforums/
    then give 777 permissions to the conf/, cache/, and uploads/, folders like this:
    chmod 777 vanillaforums/conf/ vanillaforums/cache/ vanillaforums/uploads/

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    Oh man. . . i'm gonna need my hand held here.

    Would i do this through terminal? I would assume you are talking about server side command lines though right?

    I don't have anything weird with my iMac here in my office. . .i was assuming it would just work.
    I have a Macbook at home if that changes anything.
  • Options
    edited October 2010
    Okay, i played around some more. . . including downloading a new version. . . they must've just changed from .10 to .11.

    I'm trying it from Macbook at home now, and i get a new error -

    "Parse error: syntax error, unexpected ',', expecting '(' in /homepages/26/d343337235/htdocs/vanilla/bootstrap.php on line 64"

    I don't want to give up on Vanilla just yet. . . it looks good. . . but this is really annoying to be days into it and not even messing around yet. bbPress installed in 1 minute without any issues on the same exact computers.

  • Options
    edited October 2010
    Turns out you can edit code right in Transmit 4. Sweet.

    As per my error above - here is what's on line 64 in the bootstrap.php file

    Gdn::FactoryInstall(Gdn::AliasConfig, 'Gdn_Configuration', PATH_LIBRARY_CORE.DS.'class.configuration.php', Gdn::FactorySingleton);

    Which ',' do i turn into '(' ???
  • Options
    edited October 2010
    Oh the saga. I talked to 1and1 to make sure i was using php5, which is what another post suggested checking. I was told to make a .htaccess file with the code:

    AddType x-mapp-php5 .php

    and upload it to the server. I did this, and i'm still getting the exact same syntax error. Argg.

    I also tried 755 and 777 on the suggested files/folders. . . same error still.
  • Options
    Did you edit bootstrap.php? Try downloading a new one and overwriting your old one.

    Anyways, lines 63 to 65 look like this for me:
    /// Install the configuration.
    Gdn::FactoryInstall(Gdn::AliasConfig, 'Gdn_Configuration', PATH_LIBRARY_CORE.DS.'class.configuration.php', Gdn::FactorySingleton);
    $Gdn_Config = Gdn::Factory(Gdn::AliasConfig);

    Which is fine.
  • Options
    I downloaded and uploaded a new one, twice.
    Your code is exactly the same as mine too.

    This thread:

    ...refers to it being a php4 vs php5 error - which is why i confirmed with 1&1 that i was up to speed with php5. My last post above dealt with that, but still the same error.
  • Options

    tech support forwarded me to here:

    Turns out it really was a php5 issue. I wasn't dealing with the .htaccess file correctly. I named it delete.htaccess and uploaded it. . .then within Transmit i chose to show hidden files, and changed the name to ".htaccess"

    Badabing. . . it works.


    Now i can start from the beginning with Vanilla ;)
Sign In or Register to comment.