Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Signature settings never save.

ShmizzleShmizzle New
edited October 2010 in Vanilla 2.0 - 2.8
Hello, if enter certain HTML into the "Signature code" box of my signature settings (I'm testing out the HTMLPurifier plugin, I'm not sure if it works with this signatures plugin or not) and click "Save", the progress bar keeps going and going but the signature is never saved. I don't get an error message.

A few examples of codes that don't work:

<b>Inline <del>context No block allowed</del></b>


<table> <caption> Cool table </caption> <tfoot> <tr> <th>I can do so much!</th> </tr> </tfoot> <tr> <td style="font-size:16pt; color:#F00;font-family:sans-serif; text-align:center;">Wow</td> </tr> </table>


  • Options
    TimTim Operations Vanilla Staff
    Its working fine for me. What version of Vanilla are you using?

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    edited October 2010
    Signatures works fine for me too
    HtmLPurifier may have a bug see Not working at all on case sensitive file systems. Did you read its comments?
    The HTMLPurifier plugin was dropped as a core plugin in favour of HtmLawed
  • Options
    I'm using Vanilla 2.0.11.

    I tried disabling both HTMLPurifier and HtmLawed and it still doesn't work properly.

    The HtmLawed plugin uses an old version of HtmLawed. Also, what config would you recommend I use (HtmLawed) for the safest settings so it's as safe as HtmlPurifier?
  • Options
    After some investigating, it looks like the problem was with the anti-XSS mod_security rules that my host is using. Sorry guys!
  • Options
    ShmizzleShmizzle New
    edited October 2010
    It might be useful to show an error message though. My server was returning a 403 but the addon never showed a warning or error or anything like that.
Sign In or Register to comment.