Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Problems with vanilla (Failed to import file)

edited December 2005 in Vanilla 1.0 Help
I'm trying to get vanilla installed on our website, and its root will eventually be, and I've gone successfully through the install, but now I cant load any of the pages because I get the error 'Error Message: Failed to import file "controls/index.php".
Affected Elements: Page.Import();'.

I reckon it's something to do with permissions, but I've tried everything I can think of from re-installing it (several times) and even 'chmod -R 777 forum/'.

I still get the same error...

Any ideas?


  • LOL at the "me" bug
  • MarkMark Vanilla Staff
    What that message means is that for some reason the controls/index.php page isn't being included properly.

    There are a couple of things you can do to figure out exactly what's wrong. First of all, the actual include is done in library/Utility.Page.class.php, and here is the function that does it:
    function Import($FileName) {
    	if (!@include($FileName)) $this->Context->ErrorManager->AddError($this->Context, "Page", "Import", "Failed to import file \"".$FileName."\".");
    The first thing I'd try is removing that @ symbol in front of the include statement so that you can see what the actual error is (the @ symbol prevents errors from being written to the screen). Give that a go and tell us what happens...
  • I'm gonna assume at this point that the controls/index.php file actually exists? Highly unlikely if you've reinstalled or whatever but it just might have gone walkabout.
  • edited December 2005
    "Warning: import(controls/index.php): failed to open stream: No such file or directory in /usr/web/ on line 47

    Warning: import(): Failed opening 'controls/index.php' for inclusion (include_path='/usr/web/') in /usr/web/ on line 47
    A fatal, non-recoverable error has occurred

    Technical information (for support personel):

    Error Message: Failed to import file "controls/index.php".
    Affected Elements: Page.Import();
    For additional support documentation, visit the Lussumo Documentation website at:"

    ^ was echoed when i removed the @ sign. controls/index.php does exist.

    Thanks for your help and I'd really appreciate more...:)
  • hmm. I might have missed something but it seems a *little* odd that it's referencing controls/index.php in a file under the library/ folder - to me that would suggest library/controls/index.php. Are you sure all your app paths are correct? (i could be on the wrong trail here, though)
This discussion has been closed.