Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Special characters in username

edited October 2010 in Vanilla 2.0 - 2.8
Hi guys.
I got proxyconnect up and running, however I ran into the problem with special characters.
In my users db, I have allowed the danish characters ('æøå') in usernames as these are very common here. However, when proxyconnect auto-connects and creates a user in the GDN_user table, it strips these (and other) characters away.

I found this in the proxyauthenticator class:
$UserName = trim(preg_replace('/[^a-z0-9- ]+/i','',$UserName));
It seems that everything that is not latin characters, numbers and dash and space is stripped away.
I tried to hack in my 'æøå', but to no avail.
$UserName = trim(preg_replace('/[^a-z0-9- æøå]+/i','',$UserName));

Do you have any idea how to fix this?


  • Options
    nobody? (bumb)
  • Options
    Your hack should work - I guess the regEx is correct - may you need some special code to make that letters readable for php.
    As I am German I know that problem with äöü... and there is for example ä for ä

    Are there any effects of your hack?
  • Options

    I had the same problem with french characters and I patched it the same way. Everything is working fine now :)
Sign In or Register to comment.