Please upgrade here. These earlier versions are no longer being updated and have security issues.

My embedded forum not showing up

This discussion is related to the <Embed> Vanilla addon.
shawnwshawnw New
edited October 2010 in Vanilla 2.0 - 2.8
I have an installation of Vanilla Forums at http://graygamers.com. I'm trying to embed it at http://gamingnext.com/social and, while the install seems to have went OK in WordPress with no errors, no forum shows up. It's just an empty page.
Tagged:

Comments

  • Bumping for help. Please?
  • TimTim Operations Vanilla Staff
    This is a bug we've noticed where sometimes Wordpress incorrectly adds backslashes to the embed code. Check the addon settings screen and see if there are backslashes in front of the doublequotes.

    We're working on a good fix, but for now your only recourse is to manually alter the wp_options table entry for vanilla_embed and paste an un-escaped version of the embed text there.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • I'm having a similar issue. Basically only the header portion of my forum is showing up:

    http://www.ohmpage.ca/test/

    (original forum at delayofgame.ca)

    Somehow I think maybe its something I'm doing? Or something I've done with ohmpage.ca's theme? Note I've inserted it by making a 'page' not, using any plugin.

  • RajioRajio
    edited October 2010
    Hrm when I try

    script type="text/javascript" src="http://embed.vanillaforums.com/plugins/embedvanilla/remote.js"></script


    It works fine.

    I've tried this on another friend's site too with the same results. Could it be something to do with my vanilla installation perhaps?
  • TimTim Operations Vanilla Staff
    Does your theme use any absolutely positioned elements? This could affect how vanilla calculates its own "height".

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • RajioRajio
    edited October 2010
    It might, I'll have to check. I just modified the colours of the default theme though and didn't change any positioning. that sounds like a plausable culprit though.

    By the way, Where can I find that "Embed-Friendly Theme" mentioned on the plugin's settings page?
  • MarkMark Vanilla Staff
    @Rajio - You can get the embed-friendly theme bundled with the latest copy of Vanilla at: http://vanillaforums.org/download

    I had a feeling that the bug was related to your custom theme, and I think @Tim just confirmed it.
  • TimTim Operations Vanilla Staff
    We discovered that for some reason your forum is not internally aware of its own height.

    To fix this, open themes/default/design/custom.css and go to line 23:
    #Body { ... }

    Inside that style, add the following:
    overflow: hidden; height: 100%

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • RajioRajio
    edited October 2010
    EDIT: Problem solved. I just forgot to press upload when I edited the CSS. That fixes it perectly. Thanks!
  • MarkMark Vanilla Staff
    Sweet!
  • BogusBogus New
    edited October 2010
    Hi ;)

    I have the same foul under Drupal http://dev.as4u.de/vanilla211 The plugin have I today here download. The example from the plugin going on my Drupal 7.

    Edit: I have now fix the css file, but the forum is not there ..
    http://www.drulabor.de/node/3
  • BogusBogus New
    edited October 2010
    The embed generared code was wrong
    wrong in the plugin ...http://dev.as4u.de/vanilla211/index.php?p=/plugins/embedvanilla

    rigth is http://dev.as4u.de/vanilla211/plugins/embedvanilla

    Now showing up the vanilla on my drupal 7 website

    Edit: My way is wrong ;( The dashboard was not found ....
  • I'm having the same issues with a site. My embed code looks just fine and the fixes above don't seem to help. Would appreciate any insight. Thanks!

    Embedded: http://illinoisprep.com/message-boards
    Full Forum: http://illinoisprep.com/forums/
  • Same issue for me. Unable to embed vanilla on a forum page. I've try with the '' default '' wordpress theme too. No change... :(
Sign In or Register to comment.