Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Language Developers: Please Update Your Language Packs



  • Options
    @Todd OK thanks! Sorry I missed that. Btw, I know it's not a setting you need to change often, but I think it should be far better to have a simple dropdown list to select the default locale on that dashboard page.

    I have no idea on the UTF-8 issue. All I can tell you is that I run Notepad++ on Windows 7, then upload the file with FileZilla. Hope it helps!
    In FileZilla's bookmarks settings UTF8 will be autodetected or forced unless you override it to use something else see "File | Site Manager | Charset" dialog
    The UTF8 setting is set when you create the database and probably defaulted to a UTF8 charset
  • Options
    @Todd, 've just uploaded the newest italian locale file, upgraded with reference to the new locale system provided starting from 2.0.11

    I noticed that I was experiencing the same issue @gml wrote about, and finally I find how to solve that.

    With reference to the example file the locale was set as en-CA, so I started to setup up my own as it-IT (we also have it_CH) but I noticed the issue above: as soon as I enabled the locale all my forum always stay in eng.

    I changed then it-IT to it_IT and then I re-enabled by locale, and it started to work fine.

    Hope this helps other devs to have their translation working.

    @brwa try to have a look here
  • Options
    The European Portuguese locale is mostly working fine, apart the strings that Baseline Locale does not contain, but outgoing emails fail to display properly the Portuguese specific characters in ISO-8859-1. The text email will not display the HTML entities and the backslash escape of PHP for some reason does not work.

    Anyone has a hint on what to do? Thanks in advance.
  • Options
    The email is received as text/plain utf-8. Attempts to change the charset to iso-8859-1 like, for instance, in or other places does not work.

    Would this problem occur when writing to the database or when the email is created?
  • Options
    edited January 2011
    message deleted
  • Options
    I've translated it into Kurdish language ,but i still have problem.

    I can't translate installation page ,which contain (database name ,database password ,Site Title ,...etc) .also i can't translate CHMOD error page ,where it says you have to change these chmod.

    any how to?

  • Options
    huraaa .
    thank you all
    I have finished kurdish language for vanilla
    here it is

    we are as Chawg group we will try to improve it.
  • Options
    @phreak, I might be a bit late, but anyways: Here is a complete translation to German -> German Locale
  • Options
    hi.I think create a question-answer website with using vanilla forums.But I didn't find Turkish Translation-for vanilla 2- anywhere..Could you find a solve for my problem ? Or you can say how can I translate words to my language..Thanks for helps
  • Options
    Anyone working on a Swedish translation?

  • Options
    @MKEJ Yes
  • Options
  • Options

    Todd said:
    You need to translate the PasswordRequest string to the sentence with instructions. Here is the English version:$Definition['PasswordRequest'] = 'Hello %1$s,

    Someone has requested to reset your password at %2$s. To reset your password, follow this link:


    If you did not make this request, disregard this email.';

    Isn't the normal behaviour to use English strings if no particular translations are available? I'd consider this a problem with translation engine, if partial translations cause flaws in functionality. Normally, partial trasnlations are just overridden with base language.

Sign In or Register to comment.