Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

UTF8 help me please

edited December 2005 in Vanilla 1.0 Help
hello, i'm new to this forum thing. i don't know much and i have a problem that i cant find an answer in these pages.
i installed vanilla and wow skin. then i made English.php a utf8 file.
But then i got an error which says:

Warning: Cannot modify header information - headers already sent by (output started at /data/members/free/tripod/uk/m/e/t/metruk/htdocs/languages/English.php:1) in /data/members/free/tripod/uk/m/e/t/metruk/htdocs/controls/signin.php on line 58

what is this i don't know. its my 3rd day in php. can anybody help me?

Comments

  • Options
    Maybe you left a space somewhere in your file while modifying. eg on english.php in line 1.
  • Options
    thanks. i never thought that. i am lookin'
  • Options
    no :( it's not that. because i never edited the original english.php. i only saved it as utf8.
  • Options
    edited December 2005
    and if there is no solution to this how can i prevent these header error messages to come. because when i get the error code if i refresh the page it is straightened and normal again.
  • Options
    Maybe the saving in utf8 caused a spacing? Usually such error is given when a space or any other output is send before eg a cookie is set or so (the headers). So I can only advice you to triple check the file for spaces that shouldn't be there. Maybe other people have other ideas.
  • Options
    you must be right. its 3 byte bigger than the original file.
  • Options
    edited December 2005
    Lol.. you are really right! it doesn't match. but i can't see it on notepad. i used a comparer program and it found a difference at line1 like this: <?php this is original and <?php and this is when i saved as utf8... but like i said before i cant see the first three characters in notepad so i cant delete them.. so what should i do?
  • Options
    Try another program. :) Maybe wordpad does it.
  • Options
    no, it doesn't... and i think these three hidden chararacters are in every utf8 type php files. so they can't be deleted. but then whats the problem again.. i m losing my hope..i think i basicly wont use different characters for the forum.. thnx anyway jos..
  • Options
    Download Notepad++ http://notepad-plus.sourceforge.net/uk/site.htm Open up the file. Format > Encode in ANSI, then Check UTF-8 without BOM. The BOM is your problem.
  • Options
    lechlech Chicagoland
    restore the original files maybe?
  • Options
    When he takes the original file an encodes in UTF-8 it includes a byt order mark at the beginning of certain characters. To get rid of it he just needs to encode in UTF w/o BOM.
  • Options
    yeah with notepad++ utf w/o bom solved my problem thanks very much :)
This discussion has been closed.