Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

FastCGI Error on Discussions Page

edited November 2010 in Vanilla 2.0 - 2.8

I recently upgraded my Vanilla from rc3 to the latest version, 2.0.14. I followed the instructions at, except that I didn't back up my files because our forum and database is brand new anyway.

Everything seemed to work just fine- until I tried to navigate to the main page. I'm getting the same FastCGI error I was getting before (which is when I tried the rc3 thinking it was the latest release). My webhost says they're fully capable of handling FastCGi and I have no idea how to troubleshoot this because of the non-descript error. Strange thing is, the dashboard is still fine.

I can view the activity page and individual posts even... When I clear my cookies, I access the main page, but when I enter my username and password, I get the same FastCGI error on the discussions page. Looks like it's just the discussions page I can't access, and that's only when there's a cookie stored in my browser- I can see the discussions page when I'm not logged in.

Any ideas? I have searched the community pages for a FastCGi error without luck. I feel like this is an easy fix waiting to happen, but I'm not sure where to look next.


I'm using Firefox 3.6.12, MySQL 5.0.51a, and PHP version 5.2.13.

FastCGI Error
The FastCGI Handler was unable to process the request.

Error Details:

* The FastCGI process exited unexpectedly
* Error Number: -1073741819 (0xc0000005).
* Error Description: Unknown Error

HTTP Error 500 - Server Error.
Internet Information Services (IIS)


  • Options
    Anyone know why this is such a difficult question for everyone to troubleshoot?

    For the record, I was able to install Vanilla 2.0.9 without any problem. Somewhere between 2.0.9 and 2.0.14, there's an issue in Vanilla causing a fastCGI error on my server. It'd be helpful if anyone could think of a chance that would account for this, as I may need to upgrade past 2.0.9 one day.
  • Options
    Well, a bit more data wouldn't help. I'm also using fastCGI, but haven't encountered errors or debugged the system before.

  • Options
    TimTim Operations Vanilla Staff
    You're using IIS. I hate to pull the "requirements card" because it sometimes seems like a cop-out, but we *do* specifically require Apache. We openly admit to testing only on Apache to the potential detriment of IIS, lighthttpd and nginx.

    Are you using a brand new config file? Only thing I can think of is that your old config has some old values in it... maybe rewrite urls?

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    edited July 2011
    IIS seems to be a show stopper for Vanilla 2.018 on a fresh install.
    My host has been going to a lot of effort to help but FastCGI throws a 500 error and error isn't being logged at server. In my case mod_rewrite is performed through an IIS add-on that is compatible with htaccess and it works on url's that don't throw a 500 error.

    Am able to perform basic admin functions, create users, create threads, view main discussions page however viewing a discussion thread throws error- with or without "RewriteUrls" enabled and removing htaccess file. A couple of admin functions such as trying to enable "Debugging " plugin also generate a FastCGI 500.

    If anyone has any IIS patches, helpful hints etc...would be greatly appreciated
Sign In or Register to comment.