Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla Social Connect Bonk Error

edited November 2010 in Vanilla 2.0 - 2.8
I just installed vanilla on my server, and wanted to integrate social connect to it... but for some reason, it won't work at all, I've followed all the instructions in the tutorial. You can check it out here:

Facebook just straight up won't work, I keep getting a "BONK" error, google upon signing in gives the "BONK" error. OpenID also gives the "BONK" error and Twitter for some reason, will login, but still gives the "BONK" error (so I'm guessing that's a redirect problem). Any ideas on how I can fix this? I'm a complete noobie by the way.


  • Options

    Try to go to conf/config.php , edit the line about error messages to look like this:
    $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php'; -- the default value is$Configuration['Garden']['Errors']['MasterView'] = 'error.master.php';-- reload / refresh, get the actual error, paste it here and then revert the code back to error.master.php.

  • Options
    I ended up fixing the error, it showed that the compile directory wasn't writable, so I created one and changed permissions and now it's working fine. Just one more question, I accidentally associated my main admin username with my google account (I was testing), and now it automatically logs the admin in when I click on google login. Anyway to disassociate those two?
  • Options
    The compile directory can be found cache => Smarty => compile

    Not sure if this is secure but the error stopped and now my tests are complete. Hope this issue is clarified to be a safe solution. I am new with Vanilla and I am not sure if I am doing the right thing here so use this suggestion at your own risk. Any confirmation from the developers will help others solved those who still have problems on this issue without worries.
  • Options
    what should i change for the compile permissions? is 755 or 777?
  • Options
    I set my compile directory to 777 (it was 755 when the error was happening) and it works properly now.
Sign In or Register to comment.