Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[SOLVED] Blank page with any non-default theme

edited November 2010 in Vanilla 2.0 - 2.8
Hi everyone.

I've set up a vanilla forum (latest version) using the new embed feature with my wordpress site. On the development server (my home machine) everything works fine.

On the fresh install I just did on my host, I get a blank screen if I change the default theme to the embed friendly version (or any other theme). Any ideas what could be causing this? Like I said, it displays fine with the default theme.


  • Options
    remoukremouk New
    edited November 2010
    Let's try something:
    - go to you /cache directory
    - create a "Smarty" dir if it doesn't exist
    - inside the "Smarty" dir, create a "compile" dir
    - be sure to chmod 777 those new directories

    If this doesn't work:
    - what do you mean by "blank page"? An absolutely empty page? No *Bonk*?
    - change $Configuration['Garden']['Errors']['MasterView'] = 'error.master.php'; to $Configuration['Garden']['Errors']['MasterView'] = 'deverror.master.php'; in your conf/config.php, and tell us if you see anything
  • Options
    edited November 2010
    Thanks for the response.

    I get an "operation not permitted" when I attempt to chmod that directory (using FileZilla). Upon closer inspection it seems that the owner is not me...strange.

    At any rate, those directories DO exist.

    By blank page I mean totally blank. No output whatsoever (nothing hidden in the source). Nothing changes when I modify that configuration variable either.

    Interestingly enough, I couldnt modify conf/config.php at first, because it too was owned by someone else. I had to rename it to accomplish what you suggested.

    Do you think these problems are related?

    Thank you again for your help.
  • Options
    Okay, so I renamed the cache directory (again, I was not able to remove it due to the permissions error). I then recreated the directory structure manually, and chmoded 777. Everything works now.

    Can anyone explain how or why the cache and config files had different ownership, which I could not change?

  • Options
    I can't help you a lot, I'm new to Vanilla, but I had a similar problem and it was because the application had no permission to write in those directories. So yeah, I think these problems may be related. I'd try to make this clean.

    You should also try to activate the Debugger plugin, and see if the page is still blank.

    Good luck!
  • Options
    Damn, didn't saw your comment. I'm glad it finally works!

    I guess that those directories and files have been created by the application, which is run by Apache, so the owner may be Apache (that's why you couldn't change them), and if the permissions are not set properly, well, there's a problem.
  • Options
    TimTim Operations Vanilla Staff
    The cache and config file are actually written by PHP itself, which usually does not run as your user, but rather as a server-wide user called Daemon, or Nobody, or really anything that the server administrator decides. For that reason when it creates files and folders, they take on different credentials than your user account.

    Vanilla comes with a cache/ and conf/ folder internally, which should mean that those folders retain your ownership, but their contents maybe be owned by the server.

    At any rate, it sounds like a simple permission problem and I'm glad you were able to fix it. In the future, if you have a totally blank screen you can try adding:
    define('DEBUG',TRUE); to somewhere near the top of your index.php file. This should turn on all errors and allow you to get more specific error information.

    Vanilla Forums COO [GitHub, Twitter,]

Sign In or Register to comment.