Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Wordpress integration logout problem

edited November 2010 in Vanilla 2.0 - 2.8
When I sign into Vanilla, then hit log out, it brings me back to the home page but says I am still logged in as a user with a blank name. Then if I hit logout again it asks if I am sure I want to log out of Wordpress. Then it looks like I've logged out bc I get the wordpress login page but then when back to Vanilla, I'm still logged in as the blank user.

Please help!

Also it lists the blank user as a recently created user in the dashboard.

Comments

  • @tim Can you look into this? This was one of the original problems I asked you about.
  • TimTim Operations Vanilla Staff
    Delete all your cookies, and make sure that your Vanilla cookie domain is set to the same as your wordpress one. Wordpress one is found in the wp_options table under the key 'vanilla_cookie_domain'. Vanilla one can be changed from the ProxyConnect config screen

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Awesome, thanks!
  • edited November 2010
    Hmm I'm in the wp-options table and I don't see any vanilla keys besides vanilla_sso_key. Plus the cookie domain can only be changed for ProxyConnect if it's a manual integration. The default value, however, is my blog URL
  • @tim I've tried everything. I set my cookie domain in my wp-config file to .highexistence.com, deleted all cookies and it's still messed up.
  • Here's one way it occurs:

    I log into Wordpress with my admin account then go to Vanilla. It either 1) shows me as being logged in as my username on Wordpress or 2) shows me as a blank user.

    Also it never asks me to link my Vanilla account and my Wordpress account. At one point in the menu it was showing my username as my wordpress username followed by the number 1

    Confusing!
  • I swear it never read that there was a cookie setting in the wordpress plugin... argh now it works perfectly. Thanksss
  • TimTim Operations Vanilla Staff
    So [SOLVED] ?

    Vanilla Forums COO [GitHub, Twitter, About.me]

Sign In or Register to comment.