Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[SOLVED] Facebook & Twitter Connect Plugins don't enable

edited December 2010 in Vanilla 2.0 - 2.8
QUESTION SOLVED: Enable cURL to fix this issue!!!

They Don't Enable

Example of fatal error for Facebook Connect

FATAL ERROR IN: FacebookPlugin.Setup(); "This plugin requires curl." LOCATION: C:\xampp\htdocs\H\Vanilla2\plugins\Facebook\class.facebook.plugin.php > 271: $Error = ConcatSep("\n", $Error, 'This plugin requires the allow_url_fopen php.ini setting.'); > 272: if (!function_exists('curl_init')) > 273: $Error = ConcatSep("\n", $Error, 'This plugin requires curl.'); > 274: if ($Error) >>> 275: throw new Gdn_UserException($Error, 400); > 276: > 277: > 278: // Save the facebook provider type. > 279: Gdn::SQL()->Replace('UserAuthenticationProvider', BACKTRACE: [C:\xampp\htdocs\H\Vanilla2\library\core\class.pluginmanager.php 779] FacebookPlugin->Setup(); [C:\xampp\htdocs\H\Vanilla2\library\core\class.pluginmanager.php 762] Gdn_PluginManager->_PluginCallbackExecution(); [C:\xampp\htdocs\H\Vanilla2\library\core\class.pluginmanager.php 592] Gdn_PluginManager->_PluginHook(); [C:\xampp\htdocs\H\Vanilla2\applications\dashboard\controllers\class.settingscontroller.php 579] Gdn_PluginManager->TestPlugin(); [C:\xampp\htdocs\H\Vanilla2\applications\dashboard\controllers\class.settingscontroller.php 579] SettingsController->TestAddon(); [C:\xampp\htdocs\H\Vanilla2\library\core\class.dispatcher.php 297] PHP::call_user_func_array(); [C:\xampp\htdocs\H\Vanilla2\index.php 38] Gdn_Dispatcher->Dispatch();

I just updated to 2.0.15


  • Options
    "This plugin requires curl."

    So, install cURL :)

  • Options
    Hi, I'm Wahmad.
    I recommend trying to buy Twitter followers, they have been recommended by a lot of bloggers and they can be trusted. We've used to boost the number of followers for a few of our clients and they're all satisfied
  • Options
    @Lincoln spam spam spam
  • Options
    thx cdavid, but most of us using vanilla have little or no idea on php, what is curl.? where to and how to install?
  • Options
    php info on server says curl is enabled

    cURL support enabled
    cURL Information libcurl/7.15.5 OpenSSL/0.9.8o zlib/1.2.3 libidn/0.6.5

    but the facebook, twitter etc still wont enable :((
  • Options
    ok, let's try this again...

    You should check if cURL is also installed on your machine (the actual program, not the PHP binding):

    If Linux on a machine on which you have access, what do you get if you run:
    cdavid@idea:~$ curl --version curl 7.19.7 (i486-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/ libidn/1.15 Protocols: tftp ftp telnet dict ldap ldaps http file https ftps Features: GSS-Negotiate IDN IPv6 Largefile NTLM SSL libz (this is what I get on my machine).

    If on Windows, make sure you have curl installed (don't quite know how since I don't use Windows) and if not, install it from here:

  • Options
    edited December 2010
    The error trace message above tells me curl is *NOT* either installed and/or active in your localhost Windows XAMP installation.
    You are not using LAMP or MAMP (which are the localhost alternatives for Linux and Mac platforms respectively).
    cURL (often implemented as libcurl) is a command line tool for transferring data with URL syntax see (i.e. I googled it)
    Also have you setup the facebook and twitter applications as per the Tutorial and/or Twitter and FaceBook pages RTFM ?
  • Options
    Enabled cURL
    There was no need to manually install. It was already implemented
    All works fine.
  • Options
    I'm having the same problem the Curl is enable by default but still doesnt work, any suggestion?
  • Options
    I'm also getting "This plugin requires the allow_url_fopen php.ini setting." When trying to enable the Facebook plugin.

    My server has cURL enabled, and they were also helpful to add a php.ini to my server:
    allow_url_fopen = On
    extension =
    memory_limit = 128M

    But this just makes my forum go BONK!

    Removing the php.ini from the forum-folder, makes the forum work again, but alas... Still the allow_url_fopen php.ini error :(

    Anyone know what on earth is wrong?
  • Options
    Yes I am also getting This plugin requires the allow_url_fopen php.ini setting. When I try to enable Gmail login plugin. Any help very gladly recieved. I am a bit of a noob!
Sign In or Register to comment.