Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Problem with HTML tables in Discussions.

edited December 2010 in Vanilla 2.0 - 2.8
I wanted to post a table in one of the discussions in my vanilla 2.0.16 Forum and i got the following problem.

table code typed in the discussion box:

<table style="border: 1px solid #000000;"> <tbody> <tr> <td>Cell 1.1</td> <td>Cell 2.1</td> </tr> <tr> <td>Cell 1.2</td> <td>Cell 2.2</td> </tr> </tbody> </table>

and the resulting output in html code:

<br> <br> Cell 1.1 Cell 2.1 Cell 1.2 Cell 2.2 <table><tbody> <tr></tr><tr></tr></tbody></table>

How can I get the table code working properly? Code like <img> or <ul> works fine.


  • Options
    I assume it's because of the filtering taking place when you put HTML inside your comments. Do you have HtmLawed or any other such plugin installed on your distribution?
    It would really help if you could take a look here and provide more details about your platform.

  • Options
    edited December 2010
    The system is a web hosting package from a web hosting provider. I have no clue about the detailed specs.The system is a Fedora linux system, with Apache 2.0.48, PHP 5.2.5 and a MySQL Database with server version 4.1.21-Max. But i'm fairly sure it isn't a problem with the web hosting package. If I post the same code in this forum here, i get the same results:
    Cell 1.1 Cell 2.1
    Cell 1.2 Cell 2.2
    Just check the code of the above line. I am using Firefox 4 Beta 7 to view this.

    The plugins I have activated on my forum are "Emotify :)", "Last Edited" and "Poll". Strangely it says, there are 4 plugins activated. Applications are "Vanilla" and "Conversations".
  • Options
    I was more interested in what plugins / applications / Vanilla version etc. since this seems to be a problem of Vanilla.

    I think the problem is that the Vanilla formatter does not allow tables in the document, rather just a, img and others. You don't have HtmLawed installed, so I assume that the default Html formatter of Vanilla kicks in. I'm trying to look up where that comes in, but @Lincoln might help more.

  • Options
    Ok, HtmLawed is not listed on the plugin page but it is in the plugin directory on the server. I renamed the directory and now all html code is displayed as code and nothing is interpreted. Maybe it is a problem with my MySQL Database, as it is Version 4, not the required 5.
  • Options
    I don't think so, because the same behavior appears here, on Which means that HtmLawed actually gets in Vanilla and, more than that, it is the one disabling tables.

  • Options
    TimTim Operations Vanilla Staff

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    I checked the config.php, and HtmLawed listed as activated. I commented the line out and the plugin list showed now the correct number of activated plugins, although HtmLawed is not in the list of the deactivated plugins. The html code is not interpreted at all, when HtmLawed is deactivated, even is not working.
  • Options
    MarkMark Vanilla Staff
    This must be an HtmLawed issue - which is in the jurisdiction of @Todd
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    If you don't have HtmlLawed in there then all html is just encoded so that people can't wreck your pages. I'll have to have a look into the problem with Htmlawed, but until then you can try the Html Purifier plugin instead.

    You can find it here:

    Make sure you disable Htmlawed and enable Html Purifier.
  • Options
    I have deactivated HtmLawed and activated Html Purifier but no html code is interpreted. Btw HtmLawed was set as hidden in the class.htmlawed.plugin.php, so i could'nt find or deactivate HtmLawed on the plugin page.
Sign In or Register to comment.