Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Vanilla screwed up on new server

edited December 2010 in Vanilla 2.0 - 2.8
after moving to a new server, somehow my vanilla installation does not work anymore :(
Using version: 1.1.4.
I am trying to fix it so I can update to version 2 as described in the upgrade instructions: 1) log in as root user 2) backup the database etc...

Here are the problems:
1) Logins does not work (database connects ok, disscussions are displayed and browsable though)
2) session cookies are stored on the computer, but after successfull login, the landing page is shown as if no login was happening at all
3) I tried to reinstall (reconfigure). Called /conf/settings.php. After recognizing that a reinstall would wipe my database, I cancelled that. Now the landing page redirects to the setup page :( No forum is shown at all :(

Any help is greatly appreciated. Thanks

#Edit: 3) is solved - just had to set conf/settings.php "Setup_Complete" => "1"

The login problem still remains. I found some references here in the forum to some issues at github. Unfortunately those links seem to be outdated.

Or is it possible to upgrade to vanilla 2 without beeing able to login to the old installation again?


  • Login problem solved:
    It was caused by a wrong setting in conf/settings.php

    Cookie_Path should only include the relative part of vanilla installation (without domain)
Sign In or Register to comment.