Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Applicant approval not working.

edited December 2010 in Vanilla 2.0 - 2.8
Hey together.

I noticed a strange behavior of my vanilla 2.0.16 installation today. As i already mentioned in a previous question, i've got a private community running, and i'm proving that i know every applicant. Since the site is neither easy to find, nor very popular, i didn't get any applicants since i upgraded to vanilla 2.

So, I got my first applicant today (on my invitation by sending him the registration-link) and I saw in the dashboard, and on the side-panel, that i got someone to approve. I klicked on approve several times, and nothing happened.

So I logged out, and tried to create a new user. I then logged in with my admin-account again and also clicked the approve button. But (surprise surprise), nothing happend again. The only thing I saw was that my mailbox was full of "Membership Approved" mails... For every click on the button, one mail. And I recognized that several "Welcome Abord" messages where also in the activity stream...

After setting the the "RoleID" field in the "GDN_UserRole" for the corresponding users from 2 to 3, i could login with my self-created new user.

My 2 questions now are:
- Is there anything I can do to get the regular approval working again?
- Is there anything else to set except the RoleID to not get some buggy behavior for the user I approved the above explained way?

Thanks in Advance :)

Comments

  • Options
    I had that problem, but it was because I had been messing around with the config-defaults.php file and changed the ['DefaultRoles'] value from 8 to 4. Changing it back fixed it:

    $Configuration['Garden']['Registration']['DefaultRoles'] = array('8');
Sign In or Register to comment.