Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Anonymouse 2 plugin with RewriteUrls setting

This discussion is related to the Anonymouse addon.
yu_tangyu_tang New
edited April 2011 in Vanilla 2.0 - 2.8
When I set config to:
$Configuration['Garden']['RewriteUrls'] = TRUE;
then, discussion page shows no captcha.
I looked in HTML source and found a captcha URL like:
<img src="/vanilla/vanilla/plugins/Anonymouse/captcha/imagettfbox.php" />
There is a word 'vanilla' twice so it was bad URL.
I change back RewriteUrls to FALSE, captcha appears.

I run Vanilla 2.0.16 on Local XAMPP.
I tried out a number of different plugins and I like Anonymous 2. It has cool icon too!

Any solution?


  • SS ✭✭
    Any solution?
    Check your config.php
    If you have
    $Configuration['Garden']['WebRoot'] = '';
    Try to change it to $Configuration['Garden']['WebRoot'] = '/vanilla';
    or '/vanilla/'

  • SS ✭✭
    edited January 2011
    My local vanilla setup in domain root (with RewriteUrls = True), I didnt test it for directory. Thanks anyway, I'll check it later.

    Looks like a bug in Gdn_Plugin::GetWebResource()
    If vanilla setup in directory $this->GetWebResource(...) return correct web path to file, but if result pass to Controller::AddCssFile() or Controller::AddJsFile() install directory will duplicated: /forum/forum/plugins/MyPlugin/some.css
    $Sender->AddCssFile($this->GetWebResource(...); $Sender->AddJsFile($this->GetWebResource(...);

    Playing with $Configuration['Garden']['WebRoot'] is useless.
  • SS ✭✭
    edited January 2011
    Update: Fixed, removed GetWebResource(), replaced by static path for all assets.
  • @s Thanks!
    I downloaded the latest version. It works fine!
  • Downloaded your plugin today. There's still a problem with the install directory duplication. Instead of only a single /forum, it presents as /forum/forum. Problem only manifests itself when posting anonymously (post goes through, but the URL it redirects to is wrong). Can't find the offending code (I'm an amateur). Any suggestions?
  • battersbatters New
    edited April 2011
    captcha does not work, what to do to appear?
    only works once, do not correct the input image with the numbers does not appear. in the config.php file change line 36 does not work $ Configuration ['Garden'] ['RewriteUrls'] = TRUE / FALSE;

    After incorrect captcha input picture with the captcha have wrong path:

    In first input captcha have right path:

    How to fix this bug?
  • battersbatters New
    edited April 2011
    ok im find the problem, is it link in foot of page "Powered by Vanilla" (in file default.master.php) when im delete this code
    echo Wrap(Anchor(T('Powered by Vanilla'), C('Garden.VanillaUrl')), 'div');
    then captcha does not appear after wrong input.
    how to delete link "Powered by Vanilla" from foot of page correct?
  • lucluc ✭✭
    You should leave the RenderAsset('Foot') in, and remove the echo.
  • SS ✭✭
    edited April 2011
    @batters Could you give the link to your forum? I want to look.
  • @S im dont have hosting yet
  • yu_tangyu_tang New
    edited April 2011
    Ok, now I found that Cats is not the only species in this discussion. :-)
    how to delete link "Powered by Vanilla" from foot of page correct?
    Another way is to add the code to any definition file for locale.
    $Definition['Powered by Vanilla'] = '';
    You don't need to touch default.master.php, so you don't worry about upgrading.
  • webjoewebjoe New
    edited April 2011
    Thanks, I had the same problem.
  • SS ✭✭
    edited April 2011
    Hi, folks

    Uploaded new version (2.4.15):
    - new config option $Configuration['Plugins']['Anonymouse']['NoCaptha'] = False; // enable/disable captcha;
    - fixed bug with disappearance of captcha image

    Also found some things:
    1) plugin not working with vforg theme, bug:
    2) gdn.definition('WebRoot') works different for folder and root installation, bug:

    Anonymouse @
Sign In or Register to comment.