Users running a non-download version of Vanilla (pulled from github), on branch release/2019.016 or master from the last 2 weeks should upgrade to release/2019.017 or latest master for security reasons. Downloaded official open sources releases are not affected.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

Problem: iFrame Not Resizing

This discussion is related to the <Embed> Vanilla addon.
edited January 2011 in Vanilla 2.0 - 2.8
We have an issue with en embedded Vanilla forum on one of our sites. I've managed to trace it to the local.js file not being loaded. This is where the message event seems to be fired and picked up and handled by remote.js.

What's really strange is that if I replace our embed URL with this one...

http://embed.vanillaforums.com/plugins/embedvanilla/remote.js

the resizing happens as it should. Even a fresh install was broken. Would love to have a fix for this... please!?

Comments

  • MarkMark Vanilla Staff
    Do you have any plugins on your forum? Or maybe your container page has javascript that is messing it up. I'd install firebug and test it on firefox.
  • Thanks for the response. I discovered that the config file was messed up and have since found and fixed the problem. I don't know how the config got into the weird state it was in to begin with but changes are saving. All is well.
  • Thanks for the response. I discovered that the config file was messed up and have since found and fixed the problem. I don't know how the config got into the weird state it was in to begin with but changes are saving. All is well.
    hey can you let me know how you fixed this issue please
Sign In or Register to comment.