Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Upgrade V1 > V2: Thats a weird process?

phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
edited January 2011 in Vanilla 2.0 - 2.8
Hi all,

Upgrading doesn't work for me and i 'm not sure what is going on here. I explain here in short. The forum dump is very small (around 30 discussions).

1.) I read the documentation of the upgrading process.
2.) My Vanilla 1 forums runs in version 1.1.5a
3.) I used the latest export2vanilla.php in version 1.3.1

> When i hit "Begin Export" a page appears with the database-data (no file gets downloaded, nor does an option or checkbox appear saying this).

4.) I copy and paste the data into an editor and saved it to my desktop naming it "export2vanilla.txt".
5.) I open the "Import"-page in the dashboard of my new forum (V 2.0.16).
6.) I upload the "export2vanilla.txt" and once it appears i hit "Import" on the button.

> I receive the message that "You've successfully uploaded an import file. Please review the information below and click Start Import to begin the import." and hit the "Start Import" Button at the bottom.

7.) Then i get to a page that shows a red error message: "The import file does not contain any data.", "Initialize" is crossed out and the import sequence seems to be stuck at the "Process Import File".

Mmh, tried it several times i think there is something wrong with the exported file.
Does anyone have an idea?

Thanx for help,
Stefan
  • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
  • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla

Comments

  • Options
    TimTim Operations Vanilla Staff

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    It's possible that your cutting and pasting is the problem here. Put the vanilla2export.php file in a folder that has write permission and you should see the checkbox. Try importing through that method.
  • Options
    phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited January 2011
    Hi Todd,

    Thank you that was the case. I managed to do an import, but another interesting thing happened:

    I'm converting a german board, and whenever a special character like ä, ö, ü, ß, etc. appears in the title or in the posting text, it just ends there. Looks like:

    "Ich sehe gr" (< its like that, ist just stops the word)
    "Ich sehe grüne Wolken" (< should be like this) (Means: "I see green clouds" ;) )

    I took a look into the exported file: Substitutions for the special characters are there. But the didn't make it to the database, seems like the importing function can't handle them.

    I assume some other members encountered the same problem. Is there a fix for this?

    Thanx
    Stefan
    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • Options
    phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    edited January 2011
    *sensuallyPumping* ;-/
    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    Hmm. I've not had problems with unicode myself. Two things:

    1. Did you run the porter on your live database or on a backup of it?
    2. Would you be willing to send me a copy of your export file so I can have a look?
  • Options
    phreakphreak Vanilla*APP (White Label) & Vanilla*Skins Shop MVP
    Hi Todd,

    I found the solution. The exported TXT was in Latin and i changed the document to "unicode utf8", now it worked.

    (Others encountering the same problem, use a text-editor to set another text-endcoding).

    Sorry, for bothering you Todd and big thanx! Export works great once everything is in position. :)

    Greetz
    • VanillaAPP | iOS & Android App for Vanilla - White label app for Vanilla Forums OS
    • VanillaSkins | Plugins, Themes, Graphics and Custom Development for Vanilla
Sign In or Register to comment.