HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

openid (bonk page), google login (403 error). Twitter & Facebook work fine

* This error is occurring due to a server config, the logins work perfectly on my other server.

1. allow_url_fopen is enabled.

2. Upload, cache, and config folders set to 777.


WRITING a good request for help:

1. Tell us about your platform. Hosted with hostgator, linux, php 5.2.15

2.Tell us about your install. New install, 2.0.14.

3. Describe what you were doing when the problem occured. Failed on install. I removed and re-uploaded the google and openid plugin but that did not solve the issue. This same error also occurs in a completely separate directory where vanilla 2.0.14 was installed for a client.

I'm pretty sure it's something with my server config, but I've tried every option I can think of.

The htaccess file in the main directory of the forum has been updated to reflect the location of the forum 'RewriteBase /forum'. I also tried with this line commented out, same result. In the root directory of my main site I use mod_rewrite. I removed this file temporarily to see if there was a conflict, but I still got the 403 error.

Specifically this error occurs when you attempt to login using google login, or in openid after you submit you login information.
Tagged:

Comments

  • I re-verified that allow_url_fopen is on, it seemed to be the solution for another user. It is on in the php info page. I can get a bonk page when I attempt to login with openid, here is the error report..

    The error occurred on or near: /home/penzance/public_html/forum/plugins/OpenID/class.lightopenid.php

    134:
    135: protected function request($url, $method='GET', $params=array())
    136: {
    137: if(!$this->hostExists($url)) {
    138: throw new ErrorException('Invalid request.');
    139: }
    140:
    141: $params = http_build_query($params, '', '&');
    142: switch($method) {

  • You ever find a fix for this? I'm having the same issue. Also hosted at hostgator.

  • I have a similar issue. I'm suspecting it has to do with htacess (something to do with the dots in the URL.

    myurl/entry/openid?url=https%3A%2F%2Fwww.google.com%2Faccounts%2Fo8%2Fid&Target=%2F&display=popup

    I initially had the issue with the facebook login (as I was asking for the publish_stream permission). In that case, the url came back with an error message (something like go to developer.facebook.com for for more information). Trying the url without the facebook link on it worked, so this is why is suspect the dots hae something to do with it :angry:

  • AdrianAdrian Wandering Spirit Montreal Vanilla Staff

    The Facebook issue is something we fixed on master. The publish_stream permission is now called publish_actions. You can grab from Github:
    https://github.com/vanilla/vanilla/tree/master/plugins/Facebook

    For Google, you should use the Google+ plugin available on Github too.
    https://github.com/vanilla/vanilla/tree/master/plugins/GooglePlus

    I know the OpenId plugin is being reworked for Google, since they (Google) deprecated OpenID 2.0 in April.

    Hope that helps.

    R_J
Sign In or Register to comment.