Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Chinese titles result in "Bad Request" and "403 Forbidden error"

edited January 2011 in Vanilla 2.0 - 2.8

I set up a forum using the latest vanilla and it's ok with English title and whatever comments. But whenever people post a title in Chinese, they will get this error page:

"Bad Request

Your browser sent a request that this server could not understand.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request."

Even I have added the Simplified Chinese locale and the problem is still there...

I am using FatCow and the database is MySQL.

Could you please give some suggestions about how to resolve this problem?



  • Options
    Hi all,

    I have just found the answer by myself :D

    The problem is because current vanilla set rewriteurls on by default, which will turn the url into a clean url mode, where the chinese title will become part of the url. Then apache, which is used by fatcow, doesn't support url with special characters. And thus comes out the 400 Bad request error.

    To solve the problem, simply modify conf/config.php

    $Configuration['Garden']['RewriteUrls'] = FALSE;

    Then it should be fine.

    In case anyone got stuck by the same problem :-)
Sign In or Register to comment.