Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Anyone else have a problem with emoticon or emotify not working

abrownabrown New
edited January 2011 in Vanilla 2.0 - 2.8
With emoticon text emoticons not switching to icons and with emotify drop down not working. Version


  • I'm testing and it works when posting and also when choosing from the text box. It shows five rows of icons.
  • which one?
  • I tried the emotify plugin.
  • which browser are you on and what platform?
  • edited January 2011
    I've tested in both firefox and chrome under linux. Are you not seeing anything at all?
  • I see the little happy face with the down arrow and my curser turns into a pointer when I hover over but then nothing. I tried firefox and safari on mac. Thought adblock might have something to do with it but no. I also disabled wysiwyg editor but that didn't seem to have anything to do with it either.
  • Just tried it on ie and it works. I'll try emoticon and I suspect that'll work too.
  • abrownabrown New
    edited January 2011
    In ie, vanilla won't let me sign in in the embed version but I can do so in full screen but cannot type in the text area when starting a discussion (problem with wysiwyg addon), emoticon crashes the browser. Emot addons go from graphic to text which is kind of backwards. So I guess jettison all three and focus on embed sign in issue. Thanks.
  • edited January 2011
    I think I have the same problem.
    On IE8, the emoticon button has no effect but fires a javascript error in local.js (line 106, char 13, code 0, 'undefined is either Null or not an object')

    On firefox, same thing: line 106: "href is undefined".

    This only happens when using the plugin and effectively embedding Vanilla in a wrapper.
  • oliverraduneroliverraduner Contributing to Vanilla since 2010 Switzerland ✭✭
    @abrown my plugin "Emoticons" is not working in 2.0.17, if you have your forum in a webroot (like /forum/). I posted this issue on github:
  • @gwenl

    Since you are having problems with emoticon, have you tried emotify?
  • @chuckD
    I'm a new Vanilla user, I just installed my first forum using version
    The problem I described actually applies to emotify, not emoticons.
  • Yes, emotify works in ie, but not in safari or firefox. In any case, it doesn't matter as it seems that it turns graphics into text, which seems backwards to me. I went with tinymce with medium preference instead.
Sign In or Register to comment.