Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Email Subscription Not Working For Me...

edited February 2011 in Vanilla 2.0 - 2.8
Hi there, @cdavid. I'm no programmer. I installed the plugin and have tried to get emails by using a "local email server" (the Vanilla option if you don't use an SMTP) and also by using an SMTP relay. While using the Vanilla option I never receive an email even though I get a gold star and if using a gmail SMTP I always get a page long error. Can someone please help me?

I have used gmail smtp and also my own private ISP smtp that I *definitely* know the way around and it is still not working. Have tried all variations of SMTP ports and security.

Here is the error I get when using SMTP:
SMTP Error: Could not connect to SMTP host. exception 'Exception' with message 'SMTP Error: Could not connect to SMTP host.' in /home/content/a/m/m/ammaga/html/forum/library/core/ Stack trace: #0 /home/content/a/m/m/ammaga/html/forum/plugins/EMailSubscribe/default.php(73): Gdn_Email->Send() #1 /home/content/a/m/m/ammaga/html/forum/library/core/class.pluginmanager.php(353): EMailSubscribe->PostController_AfterDiscussionSave_Handler(Object(PostController), Array, 'postcontroller_...') #2 /home/content/a/m/m/ammaga/html/forum/library/core/class.pluginmanager.php(306): Gdn_PluginManager->CallEventHandler(Object(PostController), 'PostController', 'AfterDiscussion...', 'Handler') #3 /home/content/a/m/m/ammaga/html/forum/library/core/class.pluggable.php(122): Gdn_PluginManager->CallEventHandlers(Object(PostController), 'PostController', 'AfterDiscussion...') #4 /home/content/a/m/m/ammaga/html/forum/applications/vanilla/controllers/class.postcontroller.php(174): Gdn_Pluggable->FireEvent('AfterDiscussion...') #5 [internal function]: PostController->Discussion() #6 /home/content/a/m/m/ammaga/html/forum/library/core/class.dispatcher.php(297): call_user_func_array(Array, Array) #7 /home/content/a/m/m/ammaga/html/forum/index.php(38): Gdn_Dispatcher->Dispatch() #8 {main}


  • In general, my plugin has nothing to do with the e-mail sending feature of Vanilla. The idea is that I use core Vanilla functionality, so if I'm right, you should not receive any e-mails at all from Vanilla -- try creating a few accounts with e-mail addresses at the same provider as you and see if you receive any e-mail ... this happened to me with GMail too, it would not work when running Vanilla on my machine, but only when running it live because GMail would not accept my e-mails because I was running on localhost.

    But this can be from a number of causes, but most likely you can check for them in your /var/mail/ folder to see why the sending failed (since I assume it failed) -- if you are on a Linux machine. I'm sorry, but I don't know how e-mails are handled in Windows.

  • @cdavid,
    Thanks for your prompt response. Everything you just said was Greek to me. I'm on a Mac. If I get the gist of what you are saying then I take it that my problem lies with core Vanilla functionality and not your plugin, correct?
  • Pretty much, yes. There might be several problems on your machine...

    0) you don't have a mailserver
    1) you don't have a php-mail extension (but Vanilla should report an error)
    2) it's not properly set up (check your /var/mail folder -- I assume it's there since Mac is Unix)
    3) the mailserver is not accepting your e-mail (again, check your /var/mail folder)
    4) other...

    Best thing, as I said, is to check whether you can receive any Vanilla e-mails at all. Then, we can do further debugging.

  • @cdavid,
    Thanks, friend. No need for all of that. I'm now successfully using your other extension where people check the box to send it out. I gave all "members" permission to do that. It rocks.
  • Hmm...
    I'm not getting any e-mails with the plug-in, although I am getting notifications of private messages.
  • I am having the same error as jagadeesh. It appears however that the emails are being sent since I do get one myself. I have not tested fully but it doesn't seem to happen when a text post is made but when I attached a PDF the post stalls and I get the same error as jagadeesh but I still receive an email notification. Any help? I am using gmail as my smtp server in Vanilla's email setup. I am not technical enough to understand the posts above.
  • Hmm. @Dan+Devine I don't understand your problem, can you please elaborate?
  • I am getting the same error message as the author of this post however after a long stall before I get the error message I do receive the notification email. If I hit "cancel" during the long stall while posting the post goes through, I get the notification email, and the discussion does post with no error message. Hope this helps. This usually happens when I am trying to post a discussion with an attachment using the file attachment plug-in. I am using gmail's stmp server set up in the dashboard of vanilla. As you say it may be a vanilla problem but I don't fully understand how to debug it. I thought just setting up the mail settings in the dashboard was all I had to do.
  • I think what everyone is saying is the same issue I have with this plugin - it doesn't appear to work.

    Without the plugin installed.
    Any discussion "starred" (bookmarked/favorite-ed) send an email from Vanilla using default mail options (PHP mail functions) or with an SMTP server set.

    With the plugin installed.
    Starred discussions still send an email. Any others "subscribed to" via the plugin do not generate an email.

    I guess the question everyone has is how do we troubleshoot this?
    How are you sending email? Obviously the PHP and SMTP options for sending mail in the Vanilla core are working for us .. but the plugin is not.

Sign In or Register to comment.