Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Installation issue with

edited January 2011 in Vanilla 2.0 - 2.8
I'm having trouble completing the installation. The script keeps giving me :

Are you sure you've entered the correct database host name? Maybe you mistyped it? The database reported: SQLSTATE[HY000] [2005] Unknown MySQL server host '~~Invalid~~' (1) You must specify the name of the database in which you want to set up Vanilla.

My server is Ubuntu 10.04 with all the prerequisites. The database i've created is accessible with the mysql client and the same credentials I give to the installer. I tried to use the machine's hostname and as the database server without success. I also tried to use the root MySQL user and (temporarily) give full access (777) on all the files in the vanilla path. No errors appear in the php or MySQL logs of the machine. Using the "Install Vanilla without a .htaccess file." option.

I really want to try this forum solution (for the first time) as it looks great but I'm a little frustrated now and I need some help.

Apache : 2.2.14
PHP : 5.3.2
MySQL / PDO_mysql : 5.1.41



  • Options
    Assuming '~~Invalid~~' is the actual error that you are getting it sounds like it's reading/validating the config correctly. Is this a fresh install or an upgrade/replace of an older version?
  • Options
    I've copied the exact error as displayed after the form is submitted. This is a fresh install. As I said, that's my first try ever with Vanilla. I'm a french speaking person so, is there a possibility that it is related to the locale of the system (just guessing)?
  • Options
    Hmmm, just tried to start from scratch (deleted the entire vanilla directory and extracted the files again) and all seems to work now. The only thing I did differently is to extract the files directly in the root of the web directory, instead of creating one named vanilla first (extracting to /vanilla/vanilla/...). The first time, I had to move all the files one folder up to have it in /vanilla and delete the /vanilla/vanilla empty(?) folder. The problem may have been caused by some (hidden) files not moved properly.

    Anyway, it works now. Time for some testing. Thanks :)
  • Options

    I'm running into the same issue you did with the current version of vanilla, I extract the .zip file which put things into vanilla/. I then cp -r ./vanilla/* ./ to get everything running under the root and it's failing. Have the devs looked into this issue at all?

  • Options

    It looks like the option to not require .htaccess is entirely broken. The solution I had was to actually copy over .htaccess despite me not using it since I am on nginx. No idea how that works in the code that not having htaccess causes a MySQL error to show up, but that's what happened.

Sign In or Register to comment.