Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

New WordPress Plugin

edited January 2011 in Vanilla 2.0 - 2.8
@mark @tim I broke something installing the new WP plugin

I was previously using the older one which came with the plugin. I deactivated it then installed your new embed plugin that comes with the latests release of Vanilla.

...I haven't had he chance to upgrade my Vanilla yet, but I wanted to get the widgets included in the new plugin.

The trouble:
I'm getting this error:
Warning: call_user_func_array() []: First argument is expected to be a valid callback, 'vf_embed_menu' was given in .../wp-includes/plugin.php on line 395
Additionally, Validate and Save button doesn't work. The widgets are also not available.

Is a problem with the plugin, or probably something on my end? Can you translate that error message into layman's terms?

I downloaded the plugin from here:


  • MarkMark Vanilla Staff
    Doh! I've pushed up a new version of the plugin at the same location:
  • @mark uploaded your new version...still getting the same error and issues...
  • MarkMark Vanilla Staff
    What version does it say you have of the plugin on the wp plugin management screen? If it's not 1.0.2, then you didn't get the latest version.
  • edited January 2011
    I'm also having an issue with the WP plugin. Whenever the plugin is activated in WP, the page url field on the edit page gets messed up(screenshot: I tried deleting it > installing it again twice to no avail.
    Also, when I go to enter my forum url in the admin settings it refuses it every time except once randomly. Now, after a reactivation, it's not accepting it at all.
    I just have no idea what's going on, haha. Any suggestions? Thanks!

    My forum is in located in a directory/subdomain (ie., but since it worked once, I'm assuming this isn't a factor, but confused as to why it did then but not now.
  • I was having this problem too with v1.0.1 but v1.0.2 fixes the issue. Thanks.
  • Same here. The plugin version that comes with the vanilla installer is still 1.0.1. Please update the vanilla core file with the new plugin version. Glad I found this thread. :)
  • The 1.0.2 plugin seemed to work OK regarding embedding the forum, but it caused a weird graphics glitch in my Wordpress admin page.

    The slug editor input field is compressed and the "Edit" and "View Pages" buttons overlap the edit field. See examples here: and here

    Before installing the plugin the edit field and buttons looked normal. Anyone else having this problem?
  • edited January 2011
    @jcmilton, Are you using a subdomain or subdirectory? My WP plugin isn't recognizing my forum url. I've tried both a subdomain and subdirectory, but neither work.

    Would love to get this figured out. Heard a lot of great things about Vanilla, but quickly losing favor with these unresolved glitches.

    EDIT: and i AM using v.1.0.2. of the plugin, but....nothing.
  • edited January 2011
    @dave_moz I had to keep the standalone Vanilla ProxyConnect for WP3 plugin active in order to get the new VanillaWordpress plugin to recognize the forum url. I can only assume that's because the sso portion of the new WP plugin is commented out and not functional at this point.
  • edited January 2011
    @Cablespider Thanks! I did find that on the addons site, but I'd love to get the regular plugin working since so many people on here already have been. I guess I'm just trying to figure out what's making my install work improperly every time. I'll try ProxyConnect, but I'm still actively looking for a fix to my plugin problem.

    That's also not working. I currently have a static homepage on my WP site. Would that interfere when I try to punch in my blog address?
  • @dave_moz I'm using a subdirectory. I also have a static homepage on my WP site and my Vanilla forum is installed in the subdirectory "Vanilla" like this: .

    Here's how I got the embed plugin to work for me:

    As I recall, Vanilla setup a Wordpress page with the title of "Discussion" and the slug was I changed the page name from "Discussion" to "Forum" and changed the slug line to

    In the Wordpress Plugin settings under Forum Administration where it says: "Tell WordPress where your Vanilla Forum is located" I put (that's where it's installed).

    In the Vanilla section where it says: Forum Location in WordPress - Define where to access your Vanilla Forum within WordPress, that is set to: Underneath that is the embed code you can get from the Forum Code in your Vanilla admin page.

    Does that help?
  • A new version of the plugin has been uploaded here this should resolve most issues.

    We are still working on the plugin, and we appreciate all feedback.

    There was an error rendering this rich post.

  • @digibomb Thanks for the new version. Is there a changelog somewhere so we can see what has been fixed/changed?
  • Version 1.0.3. worked first try. fantastic! thanks so much. just trying to get the embed to work now, haha. got the embed code on the WP page I want, but nothing's showing up. Pressing on...
  • @jcmilton
    @digibomb Thanks for the new version. Is there a changelog somewhere so we can see what has been fixed/changed?
    I'll talk with @Mark and get one up as soon as I can.

    There was an error rendering this rich post.

  • @digibomb - I'm getting this response from the plugin: Forum url could not be validated. Are you sure you entered the correct web address of your forum?

    I wonder if this is some conflict with the Vanilla plugin?

    I installed 1.0.3 of the WP plugin, and am running WP embed plugin 1.0.1

    My forum is located in a subdirectory of my WP site.
    In the Forum Admin page I entered several variations of the url: (the actual forum location)
    and the embedded url of

    I did deactivate the embed plugin and tried again using the actual url for the forum and still received the negative response. Not sure what is going on here and since other folks got it working, I'm wondering if my trouble can even be recreated? I wonder if this is a conflict with some other plugin....?

    I really don't want to do the plugin dance...
  • edited January 2011
    So trying to get the embed to work, I deactivated the Wordpress plugin, and it once again no longer accepts my forum url to setup. My "Embed Vanilla" page has never showed the Remote URL field at the bottom either, so I'm not sure if this was one reason the actual embed never worked(even when I got the Wordpress plugin to work).

    Pretty glitchy experience so far. Any thoughts?
  • @leafboxtea, I deactivated all my other plugins and still no luck. Can't for the life of me figure out why it would work once, then never again.
    Seems like a couple people have a similar problem though.
  • The Wordpress plugin is now available in the WP repository! You can find it by searching Vanilla. If you already have it installed, your wordpress should have already nagged you about it.

    As of this post, it is version 1.0.4

    However.... @mark, I'm still not able to get the forum to validate. Are there certain requirements about this? Should the plugin be validating the forum from any url? I just can't get this sorted....
  • edited February 2011
    @digibomb - I'm getting this response from the plugin: Forum url could not be validated. Are you sure you entered the correct web address of your forum?
    I have the same error on my local development machine. These are my settings:

    PHP 5.3.0
    Wordpress 3.1 RC2
    Vanilla Forums 1.0.4 (plugin for Wordpress)

    cURL 7.19.4 support is enabled on my PHP environment

    Wordpress is located in: http://localhost/wordpress/
    Vanilla is located in: http://localhost/wordpress/vanilla/

    I am very noob at PHP, but it seems like a redirect problem. But my .htaccess file on Wordpress installation is empty.

    Printing the variable $html in function
    (/vanilla-forums/functions.php) returns the value Redirect. Don't know if could help.

Sign In or Register to comment.