Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Notice: Undefined index: * in index.php on line 1100

edited January 2006 in Vanilla 1.0 Help
I get the following error when I either remove the Assorted Files filegroup from _filetypes.xml or when I set the handler to the (undocumented) value of "None". Notice: Undefined index: * in /home/httpd/vhosts/.../gallery/index.php on line 1100 Basically, I want to only show Image and Document file types. Is there a better way to do this? Here's what I have in the filetypes XML file now: <Files> <FileGroup Name="Images"> <Extensions HandlerMethod="Image">jpg,jpe,jpeg,gif,bmp,png</Extensions> <Extensions HandlerMethod="HyperLink">tiff,tif,psd,eps,ep</Extensions> </FileGroup> <FileGroup Name="Audio"> <Extensions HandlerMethod="Embed">mp3,mid,wav</Extensions> </FileGroup> <FileGroup Name="Video"> <Extensions HandlerMethod="Embed">mpg,mpeg,mpe,avi,wmv,mov,asf</Extensions> <Extensions HandlerMethod="EmbedQuicktime">mov</Extensions> <Extensions HandlerMethod="EmbedFlash">swf</Extensions> </FileGroup> <FileGroup Name="Web Documents"> <Extensions HandlerMethod="None">xml,htm,html,php</Extensions> <Extensions HandlerMethod="None">css</Extensions> </FileGroup> <FileGroup Name="Documents"> <Extensions HandlerMethod="IFrame">txt</Extensions> <Extensions HandlerMethod="HyperLink">doc,rtf,pdf</Extensions> </FileGroup> <FileGroup Name="Assorted Files"> <Extensions HandlerMethod="None">*</Extensions> </FileGroup> </Files>


  • Options
  • Options
    MarkMark Vanilla Staff
    Sorry it took so long - weekend :)

    Change line 1100 to this:

    } elseif (array_key_exists("*", $ExtensionLibrary)) {

    I've added this fix to the download at if you just want to grab the latest version from there.
  • Options
    edited January 2006
    Thanks, I'll try it now! Will this fix be added to the development version?
This discussion has been closed.