Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

Changed physical directory at hosting provider, Vanilla blowing up

edited January 2007 in Vanilla 1.0 Help
I moved my domain from a virtual domain (which was in a subdirectory of my primary domain) to its own domain. The URL is still www.mydomain,com/forums, but the underlying directory structure at the Unix level is now different. Vanilla doesn't like this and reports a bunch of these: Warning: main(/export/home/user/public_html/www.mydomain.com/forums/library/Vanilla.Discussion.class.php): failed to open stream: No such file or directory in /export/home/mydomain.com/public_html/forums/index.php on line 15 Warning: main(): Failed opening '/export/home/user/public_html/www.mydomain.com/forums/library/Vanilla.Discussion.class.php' for inclusion (include_path='.:/usr/local/php4cgi/lib/php') in /export/home/mydomain.com/public_html/forums/index.php on line 15 I'm pretty clear that the database must have stored a full path at install time and this is causing load problems at runtime. What is the best way to correct this without losing all my posts? Thanks for any help you can provide.

Comments

  • Options
    edited January 2006
    Well, duh. It does set it as a varible when you install. Just reinstall... do you move about applications in Windows? Huh? Nope, they break.

    [ reinstall ]
    | \
    |
    *click click*
  • Options
    I would expect Windows applications to break. The Unix applications I write all use relative paths and wouldn't care if the application root directory moved. I was fairly clear on the problem, but trying to find the more elegant solution. If I reinstall, will it rcognize the existing posts in the database and keep all that as is or will it recreate the schema and lose the stuff that is built? Is the full path of the directory stored in a single location that I could easily go into SQL and change?
  • Options
    Nope, you're pooped.
  • Options
    It turns out to be a trivial fix. In case someone else encounters this problem, the reason I couldn't find the file location in the database is because it isn't stored there. The application root is set in "appq/settings.php" and you just need to change define("agAPPLICATION_PATH", "new_path"); Thanks for the help, Elliott.
  • Options
    If you did reinstall you could just import the database again over the top. Worked for me. Obviously you'd ned to export if first :P You found a solution anyway though so it's all good.
  • Options
    Yeah, at the time I thought that the path was stored in the database, so the export/import trick wouldn't work. Given that it isn't, that would have been a fine solution as well.
  • Options
    apologies for not being here 2 hours ago. I still cant do the getting up in a morning thing.
  • Options
    My approach to solving that problem is not to go to sleep.
  • Options
    I was having similar issues and I simply changed my agAPPLICATION_PATH to your equivelant of /export/home/mydomain.com/public_html/forums/ and everything just magically fixed itself.
  • Options
    yeah i also found that changing the forum path in the application settings didn't go as smoothly as i had hoped. i applied the same fix as joshua.
  • Options
    edited January 2007
    I installed Vanilla1.0.3 and have renamed the root directory from "Vanilla.1.0.3" to "BBS". I don't have an appq directory on my server, just appg, and when I search all of the files that are on the server for "agAPPLICATION_PATH" I don't find any instances. I found much of what I need to change in the "\conf\settings.php" file, Vanilla will now run when I look @ the "BBS" folder in a web browser, but my theme is gone and the board is text only. I've noticed this is only for the admin account, the only account I had created before switching the directory. Is there any easy fix for this? edit: I found my answer digging around in the database, under my account in "LUM_User" i changed my "StyleID" to 0 and "DefaultFormatType" to NULL. Everything is pretty again!
This discussion has been closed.