Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Plugin Upload New Version broken

cdavidcdavid New
edited January 2011 in Vanilla 2.0 - 2.8
Hey @Mark @Tim !

I am trying to upload a new version of my plugin by using the "Upload New Version" link. I put the zip file there (are there any constraints w.r.t. naming the file? I tried .

The archive contains the EMailSubscribe folder and a default.php inside.

Can you please point me to some documentation, if it exists w.r.t. standards about plugins (name, files), then check if the system is broken somehow and if not, I can send the code to you and you will upload it?




  • TimTim Operations Vanilla Staff
    @Todd is the one who coded that, he should respond to this :)

    Vanilla Forums COO [GitHub, Twitter,]

  • ToddTodd Chief Product Officer Vanilla Staff
    What error are you getting? You didn't say that in you post.
  • Hi, @Todd . Well, no error, just that nothing happens ... the version of the plugin does not change, the version that is downloaded is still the old version. When would that happen, because the popup says "Your changes have been saved."?

  • Hello @Todd , did you look into this issue by any chance?

  • Hey, @Todd !

    Sorry for bugging you... I was able to track what the response from the server is:
    {"FormSaved":true,"DeliveryType":"VIEW","Data":"PGgyPlVwbG9hZCBhIE5ldyBWZXJzaW9uPC9oMj4KPGZvcm0gaWQ9IkZvcm1fQWRkb24iIG1ldGhvZD0icG9zdCIgYWN0aW9uPSIvYWRkb24vbmV3dmVyc2lvbi82MzY\/RGVsaXZlcnlUeXBlPVZJRVciIGVuY3R5cGU9Im11bHRpcGFydC9mb3JtLWRhdGEiPgo8ZGl2Pgo8aW5wdXQgdHlwZT0iaGlkZGVuIiBpZD0iRm9ybV9UcmFuc2llbnRLZXkiIG5hbWU9IkFkZG9uL1RyYW5zaWVudEtleSIgdmFsdWU9IlhGNklMQjE2S05CMCIgLz48aW5wdXQgdHlwZT0iaGlkZGVuIiBpZD0iRm9ybV9ocHQiIG5hbWU9ImhwdCIgdmFsdWU9IiIgc3R5bGU9ImRpc3BsYXk6IG5vbmU7IiAvPjxpbnB1dCB0eXBlPSJoaWRkZW4iIGlkPSJGb3JtX0FkZG9uSUQiIG5hbWU9IkFkZG9uL0FkZG9uSUQiIHZhbHVlPSI2MzYiIC8+PHVsPgoJPGxpPgoJCTxkaXYgY2xhc3M9IkluZm8iPkJ5IHVwbG9hZGluZyBhIGZpbGUgeW91IGNlcnRpZnkgdGhhdCB5b3UgaGF2ZSB0aGUgcmlnaHQgdG8gZGlzdHJpYnV0ZSB0aGlzIGFkZG9uIGFuZCB0aGF0IGl0IGRvZXMgbm90IHZpb2xhdGUgdGhlIFRlcm1zIG9mIFNlcnZpY2UuPC9kaXY+CgkJPGxhYmVsIGZvcj0iRm9ybV9GaWxlIj5GaWxlIHRvIFVwbG9hZCAoMm1iIG1heCk8L2xhYmVsPg0KCQk8aW5wdXQgdHlwZT0iZmlsZSIgaWQ9IkZvcm1fRmlsZSIgbmFtZT0iRmlsZSIgdmFsdWU9IiIgY2xhc3M9IkZpbGUiIC8+CTwvbGk+Cgk8IS0tPGxpPgoJCQk8L2xpPi0tPgoJPCEtLQoJPGxpPgoJCTxkaXYgY2xhc3M9IkluZm8iPlNwZWNpZnkgd2hpY2ggdmVyc2lvbnMgeW91IGhhdmUgdGVzdGVkIHRoZSBuZXcgdmVyc2lvbiBvZiB5b3VyIGFkZG9uIHdpdGg6IFBIUCwgTXlTUUwsIGpRdWVyeSwgZXRjPC9kaXY+CgkJCTwvbGk+CgktLT4KPC91bD4KPGlucHV0IHR5cGU9InN1Ym1pdCIgaWQ9IkZvcm1fVXBsb2FkIiBuYW1lPSJBZGRvbi9VcGxvYWQiIHZhbHVlPSJVcGxvYWQiIGNsYXNzPSJCdXR0b24iIC8+CjwvZGl2Pgo8L2Zvcm0+","StatusMessage":"New version saved successfully.","RedirectUrl":"\/addon\/emailsubscribe-plugin"}

    Still, nothing happens. Can I send it to you via e-mail and you will take a look at it?

  • ToddTodd Chief Product Officer Vanilla Staff
    Yeah can you just send me the plugin and I'll check it out. todd at vanillaforums dot com.
  • ToddTodd Chief Product Officer Vanilla Staff
    Okay, so I think I see what's going on. Your plugin uploaded fine, but you gave it an old version. You uploaded 0.1.22 in Oct 2010 and 0.1.3 on 26 Jan 2011.

    You should change the version to 0.1.30. Version numbers aren't like decimals that way.
  • yeah, n00b me, changing to 0.1.30 worked. sorry for bothering.

    thanks a lot,

Sign In or Register to comment.