Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't enable Facebook Connect (1 & 1 hosting)*

edited February 2011 in Vanilla 2.0 - 2.8
When trying to enable Facebook Connect plug-in I get the following error.

The addon could not be enabled because it generated a fatal error: This plugin requires the allow_url_fopen php.ini setting.

Any ideas why this is happening?

ps. I don't think I have access to change php.ini on my host and this doesn't affect Twitter or Facebook connect for Wordpress blogs.


  • Options
    It's a long shot, but try adding this line to your .htaccess file:

    php_value allow_url_fopen 1
  • Options
    edited February 2011
    Didn't work I'm afraid. Also tried:

    php_value allow_url_fopen On


    php_flag allow_url_fopen on

    Still no luck but thanks for the suggestion. Anyone else having this issue?
  • Options
    Ok got this to work by calling my host. Here's the solution:

    1. In Notepad create a new file called php.ini
    2. Add the following line to it: allow_url_fopen = 1
    3. Save and upload to your server's folder where Vanilla forum resides.

    All is good! Hats off to 1&1 Dedicated server support!
  • Options
    Thanks, I'll close the thread then :-)

    There was an error rendering this rich post.

This discussion has been closed.