Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

unable to use SMTP server in 2.0.17.8, but same settings work in 2.0.14

edited February 2011 in Vanilla 2.0 - 2.8
First off, thanks for sharing your software, obviously you guys put a lot of hard work into it, and it shows :)

I've been testing vanilla 2, and noticed that when i upgraded above 2.0.14 ( i'm currently at 2.0.17.8), i could no longer send mail through an smtp server using the same settings that previously worked. I am testing using the "Request a new password" button, and i am getting the message that authorization has failed.

[FYI, the settings i am using are port 587 and TLS]

To confirm, i reinstalled a 2.0.14 version using an old copy of the database and config file and it works, no problem.

I *am* able to send without using a server, but would prefer not to do this a some users never receive messages.

Do you have any tips for me to try and resolve this issue other than rolling back to 2.0.14? IIRC, 2.0.17 was a security update, so i'd rather not roll back.

Thanks for your time :)

Comments

  • Options
    alright, i'm answering my own question, but maybe it will help anyone else with this issue...i added a spf record for my mail service and now it auths.
Sign In or Register to comment.