Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Need to copy vanilla install to two different servers

edited February 2011 in Vanilla 2.0 - 2.8
I have looked through the forum and not found an answer to what I am seeing.

I currently have a V 2.0.16 installation that is working fine. I have a copy of the entire directory, did an export from phpmyadmin of the current database.

I have tried two different things. Downloaded the latest version of Vanilla, which installs fine to a new database. I have tried importing the current data into a different database and then modifying the db name in the config.php to the new database. In which case I get a page that says

Bonk Something funky happened. Please bear with us while we iron out the kinks.

The other thing I tried was to import the current data into a DB. Using the copy of the current installation modified the config.php to point to that db. In which case I get the following error:

Fatal error: require_once() [function.require]: Failed opening required '/home/www/' (include_path='.:/usr/share/pear:/usr/share/php') in /home/www/ on line 529

What have I missed?? The export program that I found on this site is for version 1.x and I am already running 2.x...

I am sure it is something I am doing, or not doing, just can't see to find it...

Any help would be appreciated.


  • Options
    You will need to the delete any .ini files in the cache folder.
    I'd just copy the folders, delete the cache, change the config.php file.
    Create the new database, just import the sql using phpmyadmin.
    And you should be good to go.
  • Options
    No joy. I took the new installation, removed any .ini file in the cache folder, created a new database, imported the data from the sql file. Still get the same BONK page.

    However, on the old installation copy that did the trick! Guess I'll just run the older version for now.


  • Options
    One other note -- If I then try to rename the folder to cspot I get the fatal error there some other file(s) that need modification if I change the folder name?
  • Options
    edited February 2011

    Fatal error: require_once() [function.require]: Failed opening required '/home/www/' (include_path='.:/usr/share/pear:/usr/share/php') in /home/www/ on line 529
    @scott38301 and @garymardell,
    No. You don't delete the .ini files. The problem is destination in the .ini files. Open and edit it correctly using "find and replace" feature with your editor with the right location. Check other files as well that may contain destinations to your old server. I'm sure the cache folder is filled with them.

    I edit everything on Ubuntu with Geany. It's the best editor to me. You can open up all files or search folders with the containing text and replace it all with one click :)
  • Options
    @yanike: it's still easier just to delete the files, they will recreated right away with the correct current path.
Sign In or Register to comment.