Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[solved] installation - bootstrap.php line 57

edited February 2011 in Vanilla 2.0 - 2.8

when i point the browser to (where vanilla file structure is located) i get this error

Parse error: syntax error, unexpected ',', expecting '(' in /homepages/44/d357176027/htdocs/vanilla/bootstrap.php on line 71

i've checked out bootstrap.php and (i'm definitely not a php guru, but) i couldn't find anything wrong on line 71, or anywhere else for that matter. i've installed vanilla in the past and never run in to this issue. i even tried installing an older version (1.1.10) and it installed fine. and even if i try to upgrade that version to 2.x it still gives me the same message :(

any help/advice would be awesome, thank you :)


  • Are you using PHP 5?
  • UGH! that's what i get for assuming that just because the host HAS php5 they're actually USING it.

    i read up everything on my host's site and it all said yeahyeah php5+6 beta, this and that, but after reading your post i thought, "well, it can't hurt to just make a phpinfo file and make sure" and sure enough it was 4.x

    sooooooo thank you a bunch for that :)

    /another happy vanilla user....guy, dude, yeahhh :D
  • edited March 2011

    It seems we are using the same provider. I got the same problems but have no solution yet. Can you please tell me what you had done to get vanilla to work?

    thanks in advance
  • Got it to work now via setting up a .htaccess file
  • @mikeromeo Which setting did you make in the .htaccess file?

    There was an error rendering this rich post.

  • I encountered a very similar puzzling error in trying to start installing Vanilla
    -- My ISP had both PHP 4.0 and 5.0 installed, but the default was to use
    version 4.0. That produced this error message right at start-up:
    Parse error: syntax error, unexpected ',', expecting '(' in /home3/orangepa/public_html/vanilla/bootstrap.php on line 71

    Fortunately, the fix was easy: Just tell the system to use PHP 5.
Sign In or Register to comment.