Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Cherokee URL rewrite works fine, but...

edited February 2011 in Vanilla 2.0 - 2.8
I've figured out how to get URL rewrites to work with Vanilla. The configuration should be like so:

NOT File Exists: Rule

NOT File Exists: Handler

This means I can now write stuff like and it routes it correctly. However, Vanilla still writes URL's using index.php internally, so if I actually click "Discussions", I end up at How do I make it stop?


  • If you haven't checked it at install time, you need to edit config.php to change the parameter to TRUE. (I don't remember it's name, and I don't have access to my system right now)
  • edited February 2011
    Found it!

    $Configuration['Garden']['RewriteUrls'] = TRUE;

    Thanks! Now I'm happy :-) It's wicked fast on Cherokee.
Sign In or Register to comment.