HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

[Embed Vanilla Addon] 404 Error - Embedding Vanilla Forum into WP Site

This discussion is related to the <Embed> Vanilla addon.
edited February 2011 in Vanilla 2.0 - 2.8
A couple of weeks back, I followed the instructions to embed a vanilla forum into a wordpress site. Everything looked good, and I got it working with very little effort. However, when I came to the site yesterday, it appears the remote url for the forum is no longer working. The forum still operates properly where it resides at http://skellar.org/forum/, but the remote url page for the embedded WP page was bringing up a 404 error.

I tried re-installing the "EmbedVanilla" plugin on the forum and the "Vanilla Forums" plugin on the WP side... and readjusting all the settings... but, no dice. In the EmbedVanilla plugin on the forum side, the "Remote URL to Forum" is set to http://skellar.org/discussions/ On the WP side, the Vanilla Forums permalink is exactly that same URL, and the forum embed code is properly copied into the "discussions" page. However, when you go to http://skellar.org/discussions/, you get the 404 error.

Anyone have an idea for next steps on trying to troubleshoot this issue? Thanks in advance for your help!

[Feb. 20 - Since discussion is closed, I'm adding this comment as an edit. As everyone suggested, I too am on HG... just called them and got it fixed. It was driving me absolutely nuts trying to figure it out. I never would have thought of that as the problem. Thanks so much for sharing the resolution - really appreciate it.]
Tagged:

Comments

  • Hi Philmervis, what's up~

    I'm having the same issue as yours, but just a quick check, are you on hostgator's hosting?

    The absolute url of the vanilla forum works fine, but it's only when using the wordpress embed feature that this '404 issue' arises. Like you, after I initially installed it, everything worked fine.

    This current issue befuddles me to my wits end. Hmmm..
  • I'm having the same problem. Direct url works, but embed doesn't. I tried pasting the code directly in the post but that didn't work either. But when I used the sample code here: http://vanillaforums.org/features/embed-vanilla it worked just fine. I am using hostgator, but since the sample code works I'm stumped.
  • SamRohnSamRohn New
    edited February 2011
    hmm, the exact same issue here, vanila embed working fine until 2 days ago, then the 404's as described above

    and strangely enough, i'm on hostgator as well
  • SamRohnSamRohn New
    edited February 2011
    ok - 20 min later, called hostgator, reported the issue (and that it was being reported by others on HG)

    turns out that in my case, it was an update of modsec rules on their server and i needed to be whitlelisted - this issue is now solved for me, vanilla embed is working fine again :)

    HG tech said that this issue might be caused by different things for others, but if you are having this issue and hostgator is your hosting service, contact HG and it should be resolved in about 10 minutes :)

    sam
  • Sam, you're a saviour, you know that! Who'd knew HG was the connection amongst us?

    Btw, Sam, how did you raise the issue with HG with regards to this niggling problem we're facing?

    'Cos I'm definitely guessing that HG must've did something to their server rules, since everything worked perfectly fine a few days before.
  • Thanks sam, let's see if it's solved for the others too :-)
  • SamRohnSamRohn New
    edited February 2011
    np guys, if i hadn't seen Googooboyy's mention of hostgator i might not have finally broken down and called tech support in the 1st place, typically a last resort...

    of course, this same thing could happen to others with different hosts too, so this issue should not be considered unique to hostgator :)

    sam
  • Yup, sams advice worked. Hostgator white listed me and everything's up and running now.

    Thanks...Lee
This discussion has been closed.