Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

[Solved] Problem with facebook plugin ("UniqueID is required" error)

edited February 2011 in Vanilla 2.0 - 2.8
I am using the latest core version ( but I am having the exact problem with the facebook plugin described by usuario123 here:

This was apparently fixed by but i am still having this problem. I did not have the problem when I ran it on a shared server last week, but since moving my forum (fresh install of with no importing) to a dedicated VPS yesterday, the facebook plugin displays ""UniqueID is required" after the user enters their facebook credentials.

as usuario123 had suggested, I tried using the line:

$Args['Target'] = $_GET['Target'];

but this didnt work either (regardless, it was apparently 'fixed' since November and a similar line was already in the version I have)

Also, my server meets all the requirements and has all the necessary permissions turned on.




  • Options
    Dear friend, this problem is already solved. Please look at this topic

    Thank you.
  • Options
    Hi Alibaba31337, this is a different problem ("validate Required" vs UniqueID required)... regardless I did try the solution in that thread and it made no difference (I also have OpenSSL feature enabled for cURL as you mention in there)
  • Options
    Alibaba31337, maybe i should change all the references to URL in your solution to ID instead? I am not a programmer though, could you show me what that solution would look like? thanks
  • Options
    The thing is your application (I mean vanilla installed on your webserver) can't access facebook website. I had the same issue with It's because application can't access facebook website and can't get answer. Try to ping website from your VPS. Try to makewget on your VPS and check result in local directory, is there any html file with facebook main page? The thing here is that you have to ensure that facebook is accessible from your VPS.

    Btw, are you sure you set up the facebook plugin correctly with all keys etc. in plugin settings page?

    I see two ways where things go wrong:
    1) facebook website is not accessible
    2) authorization doesn't work because of misconfiguration of plugin
  • Options
    Here is the updated plugin Alibaba is talking about:

    Hope they gonna include it in the next version of Vanilla
  • Options
    Hi Carlo,

    Thanks for the updated file, though I tried this but still have the same problem. I inspected the code in the file you provided and can confirm that it is already the same as the one on my server because i already manually added Alibaba's solution from the other thread.
  • Options
    edited February 2011

    I tried < wget > I got the following when trying to open the file:

    it does not create a html file... just that browser php file..

    does this mean something in my VPS configuration is preventing it to log in?

    also, yes the facebook settings are all correct..


    And here is the PuTTY output when i use the wget command for facebook:

    --2011-02-25 00:58:56--
    Connecting to||:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: [following]
    --2011-02-25 00:58:56--
    Connecting to||:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 11467 (11K) [text/html]
    Saving to: `browser.php'


    As you can see, it does not create a html file, and the browser.php file does not work.
  • Options
    edited February 2011

  • Options
    If you trust me, skype me at ro31337, I'll try to help u for free
  • Options
    The thing is now we know that facebook website seems to be accessible, we need to know facebook error code. Facebook always give us error code, if you're not allowed to use it for any reason. So we just need to know error code. I think this functionality should be built inside of the plugin. Cos it's not a correct behavior when something's going wrong and user doesn't know that
  • Options
    Thanks for the very kind offer... though I already hired someone for 30 bucks to fix this up a couple of hours ago. Its taken him 3 or 4 hours so far, but i think he's almost got it now, lol.

    Will let you know how it goes and report the problem here in case anyone else needed it in the future...
  • Options
    Fixed this now. The problem turned out to be a single white space just before the Secret ID (which was the result of my dodgy copy and pasting of the keys).

    I did actually go back and check the keys several times, but i never noticed the tiny white space at the start of one of the keys that shouldn't of been there. I always check for white spaces at the end of a string when copy/pasting, but never at the start.

    ...I wasted about 8 hours and $40 on outsourcing over a single white space.

    Moral of the story:

    I am an idiot.
  • Options
    Good idea for developer to add spaces stripping for this input field :-)
  • Options
    Moral of the story:
    I am an idiot.
    @syd430 Of course you're not. There are multiple morals for this story and finding someone who could help you was amazing. It's painful it took so damn long, but that's a totally different matter.

    I'll mark this question as solved, but won't close it, because tester made an interesting remark and maybe we can dive deeper into that remark.

    There was an error rendering this rich post.

  • Options
    OMG. After hours and hours of scouring over code it was the 1 white space problem for me as well LOL... crazy.

    Anyway, I need sleep now but if you folks don't mind looking at my site forum and helping me with another problem I'm having that would be great.

    I have the forum imbedded into the blog but it seems to leave very little room to post/read, etc. Is there an easy way to change this?

    Site is brand new so still very bare but I'd like to get things up and running soon.

    Thanks in advance for any help or suggestions,

Sign In or Register to comment.