Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Install Permissions Question

edited February 2011 in Vanilla 2.0 - 2.8
I downloaded, unzipped, and uploaded the complete folder to my hosting as instructed.
When I typed the url into my browser. ( It appeared to have installed but when I put in my admin information and password I received an image of a huge red box with the following message in it....

The connection parameters you specified failed to open a connection to the database. The database reported the following error: SQLSTATE[HY000] [2002] Can't connect to local MySQL server through socket '/usr/local/mysql-5.0/data/mysql.sock' (2)

I am NOT a tech. I am just the end user. This is ALL geek to me.

Next.... I called godaddy who informed me that it was all geek to them too; they don't support this program. I came back to this forum and went here...

As far as I can tell, I did everything right but I know nothing about accessing "permissions" or what to do when I get there, and godaddy and the dog are telling :)

Can someone help please?

Thank you


  • Options
    avantime4mikeavantime4mike ✭✭
    edited March 2011
    As a novice myself I can only suggest what might be wrong. Every box on the Vanilla Version 2 Installer page has to be filled in absolutely correctly. I had a similar error to you because I had one character wrong in the database password field. Also at first I left "local host" in the Database host box but this was wrong, you need the name of your host in here (Check in MySQL).

    I just tried your URL and I get the same error without entering any info.

    Hope that helps and good luck.
  • Options
    According to this post on the GoDaddy support forums, they offer some simplified way to install Vanilla through "GoDaddy Hosting Connection". There is more evidence here that they offer installation support for Vanilla. I don't have a GoDaddy account so I cannot confirm.

    Your easiest option might be to delete the folder you uploaded, and try to use their installer.
  • Options
    Awesome suggestions. Thank you for taking the time to offer them. I shall go try both in that order, and post my results here.
    Thanks again
  • Options
    You're welcome and good luck.
Sign In or Register to comment.