Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

[Solved] Facebook Connect problem

edited March 2011 in Vanilla 2.0 - 2.8
When I try to enable the plugin, I get the following error:

The addon could not be enabled because it generated a fatal error:
"Data truncated for column 'AssociationHashMethod' at row 1|Gdn_Database|Query|insert GDN_UserAuthenticationProvider (AuthenticationSchemeAlias, URL, AssociationSecret, AssociationHashMethod, AuthenticationKey) values (:AuthenticationSchemeAlias, :URL, :AssociationSecret, :AssociationHashMethod, :AuthenticationKey)"

This is a new installation of Vanilla. I also see a similar error for Twitter. Google and Open Id worked fine.

my gdn_userauthenticationprovider table is currently empty. AssociationHashMethod is defined as enum('HMAC-SHA1','HMAC-PLAINTEXT'). I have an old database backed-up from a previous installation, and the hash method for this plugin was left blank. I tried to manually create the record using phpmyadmin, but it said no-no. I guess I thought enums could be left blank and they'd default to 0. Could it be my MySQL somehow changed to force strict checking of enums, and if so is there a way to change it?

any help from the MySQL gurus would be great?

Comments

  • Options
    Somehow strict mode got enabled on my MySQL database. This can be easily disabled in your my.ini file under the sql-mode setting. After doing this, the Facebook and Twitter plugins installed correctly.
This discussion has been closed.