Please upgrade here. These earlier versions are no longer being updated and have security issues.

recaptcha not appearing on registration

edited April 2011 in Vanilla 2.0 - 2.8
Simply, nothing appears where the recaptcha is supposed to be on the registration page. Anyone else experiencing this? (2.0.17.9)
Tagged:

Comments

  • ntuyelikntuyelik New
    edited April 2011
    if the approval is open in the settings recaptcha does not work.
    You should change your registration setting.I had the same problem until I've changed this setting.
  • It's set to "Basic", and when I fill in the form (no captcha appears) and submit it, this is the error message I get:

    "The reCAPTCHA value was not entered correctly. Please try again."

    Something is wrong.
  • So from my investigation so far, it appears that almost a year ago Google announced that they are moving the recaptcha site under the google domain:

    http://groups.google.com/group/recaptcha/browse_thread/thread/7a4839d13ac3dcf5/a51be72cd56c1461

    A couple of weeks ago they started serving an invalid certificate:

    https://groups.google.com/forum/#!msg/recaptcha/V7qswqBnA1o/JXjZjpjSR4EJ

    and I guess that that's why I'm seeing nothing on the registration page (though I would assume that more people would report this behavior!)

    Is my only option now to manually change the URLs for the captcha challenge/response?
  • lucluc ✭✭
    It's there:


    library/vendors/recaptcha/functions.recaptchalib.php:define("RECAPTCHA_API_SERVER", "http://api.recaptcha.net"); library/vendors/recaptcha/functions.recaptchalib.php:define("RECAPTCHA_API_SECURE_SERVER", "https://api-secure.recaptcha.net"); library/vendors/recaptcha/functions.recaptchalib.php:define("RECAPTCHA_VERIFY_SERVER", "api-verify.recaptcha.net");
  • I had the same problem, solved it like this:
    1)Downloaded the latest recaptcha php library from here:
    http://code.google.com/p/recaptcha/downloads/detail?name=recaptcha-php-1.11.zip&can=2&q=
    2)renamed the file "recaptchalib.php" to "functions.recaptchalib.php"
    3)replace: "vanilla/library/vendors/recaptcha/functions.recaptchalib.php" with the new file

    hope this helps someone...
  • Well, this really should be fixed in the next version -- I hope it does.
  • Thanks mortlogik! Your solution for recaptcha fix works perfectly!
  • lucluc ✭✭
    Well, this really should be fixed in the next version -- I hope it does.
    It has been modified a while back already in the unstable branch, so it will be.
Sign In or Register to comment.