Please upgrade here. These earlier versions are no longer being updated and have security issues.

Embedding in WPMU

edited May 2011 in Vanilla 2.0 - 2.8
@mark and company. I've been using an installation of Vanilla for a while at http://leafboxtea.com/discuss (in fact, this forum was featured at @Digibomb's Vanilla WordCamp presentation!). That setup is on a WPMU subsite.

I'm working on getting a new vanilla installation setup on another site (the main blog) within the WPMU. I intend to use it as a Q&A area (like stack exchange). Getting the forum setup on the subsite with the WP plugin went smoothly. But now that I'm trying to a second installation (this is a fresh install, new database and everything) the new forum doesn't validate in "Forum Administration" within WP.

So the question is, is the plugin WPMU compatible? Is there anything in the plugin that would be preventing the validation of the new forum?

If the Vanilla WP plugin isn't compatible, getting it so that it can be, would be a great addition since it would allow network managers to offer Vanilla forums to multiple subsite members depending on their needs.

Thoughts on this? Should it be working? I don't know what happens with validation so I'm not sure what to expect.

I'm running WP 3.1.2 with BuddyPress 1.2.8 (but that shouldn't have anything do with it)
The new vanilla install is Version 2.0.17.9 and the WP plugin is 1.0.5
Tagged:

Comments

  • MarkMark Vanilla Staff
    edited May 2011
    I've never tried it with WPMU, so I actually don't know the ins & outs of programming for it. The plugin was written to be installed on a single WP instance and relate a single Vanilla instance to it. I don't know why it would fail to validate another one.

    Bottom line: you can always run the forum on a custom WP page without the WP plugin installed. Just grab the embed code from the appropriate Vanilla instance and paste it into your WP page.

    The downside to this being that you don't get the WP widgets.
  • Hiya!
    I this this maybe the answer to the question that has been driving me crazt the past 24 hours. I am setting up a multi user WP site and have been trying to embed Vanilla in it. I keep getting the error - Forum url could not be validated. Are you sure you entered the correct web address of your forum?
    So I am assuming them that it can not be used on MU.
Sign In or Register to comment.