Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Am I Screwed? An unfortunate mix of embed and plugins...

edited May 2011 in Vanilla 2.0 - 2.8
I think I'm in trouble....

I have an embedded site, and I'm forcing access through the embedded site (not allowing access to the non-embedded URL). Dashboard is configured to pop-up in a separate window.

I also have Private Community plugin enabled and set to Private, so any guest sees the login form instead of any of the categories, discussions, or activities.

For some reason, the admin login doesn't work well in the embedded site. I must have tried several times to login using my admin user, and it always just returned me to the login form in the embedded site.

Thinking my admin password might not be right, I requested a password reset for my admin user.

The email had a link to click on to go to the site and reset my password. However, when I click on the link it goes to the non-embedded new password page, but then immediately gets forced over to the embedded page. Since I'm not logged in, the new password page is replaced with the regular login form because of the Private Community plugin.

Trying to go to the password entry page listed in the documentation causes me to be forced to the embedded site, which (since I'm not logged in) presents me with the embedded login screen.

Anyone see a way to fix this and regain access to my admin user account?


  • Options
    And why the heck isn't the admin login working in an embedded site? :-(
  • Options
    I poked a known password into the admin user's password field in the database. Still couldn't login through the embedded login form. :-( Why?

    Finally deleted embed Vanilla plugin and Private-Community plugin and was able to click the password reset link and reset my password and login.

    Reinstalled embed Vanilla, but the checkbox to have the dashboard not be embedded isn't showing up as an option now. Do I have the right version?

    Sign-in via the embedded login still doesn't seem to work, and sometimes I have to login twice even in the non-embedded login. :-(

Sign In or Register to comment.