HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Please upgrade here. These earlier versions are no longer being updated and have security issues.

How to disable the preview button

This discussion is related to the Anonymouse addon.
battersbatters New
edited May 2011 in Vanilla 2.0 - 2.8
How to disable the "preview button" any message when creating new topic for the anonymous user? Because it causes the error did not have enough memory on any hosting

Comments

  • i want to hide preview button at anonymouse, how do this?
  • SS ✭✭

    .AnonymousCommentForm #Form_Preview {
    display: none;
    }
  • there does not help, I added it to a file anonymouse.css but the button "Preview" to remain anonymouse
  • I have same problem with this plugin, When I click "Preview" button on creating new discussion, It show Error message (Not enough memory). Is there any fix for this ?

  • on line 346 and line 402 of class.anonymouse.plugin.php you'll find this code:

        // TODO: TEST PREVIEW IF JAVASCRIPT IS DISABLED
                            if ($Sender->DeliveryType() != DELIVERY_TYPE_ALL) {
                                $Sender->View = 'preview';
                                return $Sender->Render();
                            }
    

    comment the code and you'll get an edit screen rather than the php memory error when you preview the discussion. it's not a fix but it's far less annoying than the error.

Sign In or Register to comment.