Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Can't Drag & Drop Categories

I just installed Vanilla using the softaculous software, and immediately noticed that I can't drag and drop my categories. It seems to work in the administration area, but when I view the forum on the frontend, nothing has changed. This is quite frustrating since I need to have my categories arranged alphabetically.

Any solutions?



  • whu606whu606 I'm not a SuperHero; I just like wearing tights... MVP
    I noticed this, using IE9.

    I then tried it in Firefox and it worked fine, so I guess it is an IE issue.
  • Thanks for the tip, but I just tried Firefox and it doesn't work, either.

  • Since when was it possible to drag and drop categories from the frontend?
    There are other ways to arrange your categories alphabetically

    There was an error rendering this rich post.

  • I didn't say you could arrange the categories from the frontend.
  • It seems to work in the administration area, but when I view the forum on the frontend, nothing has changed.
    Then I must have understood and now I know why.
    The way I understand it now is that you can drag and drop the categories on the backend, but it doesn't save the new order in which you've dragged and dropped them. Is that correct?
    Also, do you only want to sort your categories alphabetically? Because you can do that in other ways than dragging and dropping.

    There was an error rendering this rich post.

  • How can the categories be arranged alphabetically without drag and drop?
  • edited May 2011
    I still wonder why this doesn't work for me. Is it because I use a Mac? Or maybe my cordless mouse? Very perplexing.
  • ToddTodd Chief Product Officer Vanilla Staff
    We use macs @ubiquitous. What browser you using?
  • Safari. But I've also tried Firefox. Same result.
  • I just tried it on Google Chrome and Opera. Same result.

    Funny, the right hand column that shows the categories is displaying the order properly. But the categories in the main body of the page are not, and that's the section I want to be alphabetical. I'm using version
  • No ideas from the developers regarding this problem??
  • MarkMark Vanilla Staff
    This is a bug in the current release version. It's been fixed in our beta, but it's not available on softaculous yet because it's not an official release. Once we are finished debugging the beta and do the official release, softaculous will have the update automagically.

    In the meantime, I believe that the fix is a combination of a jquery update, and an update to the jquery sorting plugin we used.
  • Any update on this issue?
  • This is a bug in the current release version. It's been fixed in our beta

    There was an error rendering this rich post.

  • The beta is becoming RC soon, so a release with the fix should be out in not too long.
  • I tracked this down before noticing it'd been fixed in the beta. If you're interested in patching it before the next release, the following worked for me:

    1) Open applications/vanilla/categories.js
    2) Go to line 29 and change $('[name=Form/DeleteDiscussions]') to $('[name="Form/DeleteDiscussions"]').
    3) Repeat on line 40.

    That should do it. The reason is that the / in the Form/DeleteDiscussions is considered a "special character" by jQuery, and must be enclosed in quotes to be properly read.

    Hope that helps in the mean time!
  • luc - not wanting to pressure you, but can you define "soon" as it applies to the RC? I've just gone live with a 2.0.17 Vanilla site, but I'm finding little bugs (like this one) that seem to have been fixed in the beta. Should I be updating a live site to the beta or waiting for the RC or even the release?
  • @Xaraxia: I've been running the latest beta on a live site without any problems for about a month or so. Be sure to make a backup and do the upgrade correctly, and you'll be set!

    Add Pages to Vanilla with the Basic Pages app

  • I'm using release ( and I'm not able to drag and drop my categories. Wasn't this issue fixed a few releases ago? I've tested the issue in Chrome, Firefox, and Safari--all simply highlight the text when clicking and dragging instead of moving the actual category box. Any thoughts? Thanks.

Sign In or Register to comment.