HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

[Solved] New users can't see discussions on upgraded vanilla 1.1.2 to 2.0.17

edited May 2011 in Vanilla 1.0 Help
I just upgraded from vanilla 1.1.2 to the current 2.0.17 following the instructions and using the export tool to include my old data. Everything looked okay until testing the "apply for membership".
The Registration setting is set to "basic" with the re-captcha installed, and I also have "member" as the new user role/permission.
However as a new user all I see is an empty forums which says "no discussion found", and an empty categories sidebar. I also get a "permission problem" error when accessing my "activity" and "profile" tabs.
I just realized that although my server has php 5.2.17, the database is 4.1 instead of 5.0
Dammit . . . Should I try the new install all over again, or does anyone have an idea for me to fix this issue ? Is anyone using 4.1 successfully in their Vanilla 2.0.17 ?

thanks in advance ...

burnsy
B )

Comments

  • TimTim Operations Vanilla Staff
    Check permissions for the Member role. If they don't have VIEW permissions for discussions/categories, they won't see any.

    Vanilla Forums COO [GitHub, Twitter, About.me]

  • D-oh ! My Bad. Thanks Tim, I'll try and limit the dumb questions from here on in.
    I also re-installed with a mysql 5.0 database so there aren't any issues later on.
Sign In or Register to comment.