Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Phantom text in always in comment box

edited May 2011 in Vanilla 2.0 - 2.8
I'm having a very strange thing happening, where by when I go to a discussion, I get a whole load of text already in my comment box, usually from a conversation I've already had.

It stays there, for every page load, whether I've logged out and in, or not.

Each conversation has its own specific text as well, which is always the same.

It's not a draft post - it's simply text that is already in the comment box when I get to the page.

Is this a bug, or can someone help me work out how to stop it? I've disabled all my plugins, so I'm pretty sure it's not some erroneous plugin code, or AJAX adding something after the page has loaded (but you never know).



  • Options
    edited May 2011
    OK, I've looked in the DB, and the text is actually being held in the gdn_draft table in the Body column.


    a) Why is this text being saved?
    b) Why is it being re-displayed per discussion?
    c) How is one supposed to get rid of it?

    I did discover that by actually posting the phantom comment, then deleting it, you can get rid of it, but that's not very satisfactory.

    If this is a feature, surely it should have some options to disable, otherwise, am I supposed to extend the PHP classes or something? Seems like overkill.

    Here's hoping for a simple solution.

  • Options
    lucluc ✭✭
    edited May 2011
    Draft are auto-saved after a while, and gets redisplayed in comment box.
    If you have save draft like the one you had, it would have been listed in or
    Normally the draft disappear if you post it, or you could choose to delete it for the link above.

    The link is available next All My Discussions/My Bookmarks/My Discussions (it might depend on your theme)
  • Options
    edited May 2011
    OK, I'm pretty sure this is a bug, so I'm going to log it as so.
  • Options
    ToddTodd Chief Product Officer Vanilla Staff
    This is not a bug. Auto-saving drafts is a feature that prevents comments from being lost if something happens with your browser and most modern sites have this type of feature.
  • Options
    edited May 2011

    Whilst I think the drafts feature is a good one, I don't find it's implementation very user friendly. I made some suggestion on the issues page about how it might be made (IMHO) less draconian.

    Wordpress does this better with the "There is a newer version than this" prompt I think, and I probably use the saved draft 1 out of every 15 times, so it's good that it stays out of the way, rather than forcing me to use it.

    Even Word doesn't force you to start work on an auto-save. The auto-saved documents stay in the sidebar, an only open when you ask them too.

  • Options
    New plugin uploaded which provides a Restore Draft button, rather than auto-populating the comment field:

Sign In or Register to comment.