Please upgrade here. These earlier versions are no longer being updated and have security issues.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Fatal Error in Gdn_Database.Query();

edited May 2011 in Vanilla 2.0 - 2.8
Im using Vanilla Version Installed it on localhost and uploaded via FTP but im getting this error:

Table 'p4one_6218754_bdsdb.GDN_Permission' doesn't exist
select * from GDN_Permission Permission limit 1
The error occurred on or near: /home/vol9/

232: $PDOStatement = $this->Connection()->query($Sql);

233: }


235: if ($PDOStatement === FALSE) {

236: trigger_error(ErrorMessage($this->GetPDOErrorMessage($this->Connection()->errorInfo()), $this->ClassName, 'Query', $Sql), E_USER_ERROR);

237: }


239: $ReturnType = GetValue('ReturnType', $Options);


Tried deleting lines in enabled plugins but still getting the same error. HELP! and Thanks in advance.


  • Options
    TimTim Operations Vanilla Staff
    The GDN_Permission table is created when you install the software, so either you're pointing at the wrong database, or you didn't actually install Vanilla. Either way this is an odd problem.

    You can try running the DB update script. (or

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    edited May 2011
    I can actually see the table(gdn_permission) and the result with that update is a success but i'm still getting the same error. :/
  • Options
    TimTim Operations Vanilla Staff
    1) is this the correct DB? p4one_6218754_bdsdb
    2) Do you have a backtrace?

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    Yes, it is the correct database and what is a backtrace?
  • Options
    I think you have a problem with lowercase and UPPERCASE.
    A backtrace can be found on the page you just quoted the errors from (the detailed bonk error page)

    There was an error rendering this rich post.

  • Options
    I'm pretty sure i typed dbname/username all with lowercase, i copy/paste them from the hosting server.

    Anyway, here is the backtrace and thanks UnderDog and Tim.


    [/home/vol9/] PHP::trigger_error();

    [/home/vol9/] Gdn_Database->Query();

    [/home/vol9/] Gdn_SQLDriver->Query();

    [/home/vol9/] Gdn_SQLDriver->Get();

    [/home/vol9/] PermissionModel->PermissionColumns();

    [/home/vol9/] PermissionModel->CachePermissions();

    [/home/vol9/] UserModel->DefinePermissions();

    [/home/vol9/] Gdn_Session->Start();

    [/home/vol9/] Gdn_Auth->StartAuthenticator();

    [/home/vol9/] PHP::require_once();

  • Options
    TimTim Operations Vanilla Staff
    MySQL seems to sometimes get corrupt (apparently... its never happened to me). Look for some sort of database repair utility on your host.

    Vanilla Forums COO [GitHub, Twitter,]

  • Options
    edited May 2011
    I did a repair table thru dropdown and thru command line but to no avail, it's still showing the error. I even re-import all the tables. I'll try to make a fresh install of everything later and will update here asap. Please bear with me as i really wanted to use vanilla forum as my discussion board. Thanks again.
  • Options
    Ok, i did a fresh install of everything, i made a new database, i still can see the gdn_permission but sadly i am getting the same fatal error. I just don't know what to do anymore. Anyone? Thanks in advance.
  • Options
    By the way, everything works fine on my localhost.
Sign In or Register to comment.