Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Try Vanilla Forums Cloud product
Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.

A little bug I found? Also my own fix for it.

edited April 2006 in Vanilla 1.0 Help
I'm not 100% sure if this has been mentioned before or anything (I've tried searching, didn't come up with any results though).

1) Just a side question, but is php5 not supported? If I put in the information for the database and push the next button it displays a blank page, using php4 fixes this though (I didn't search for php compatability, this is only a side question).

2) The installer works fine on the first few steps, but the step where you put your login credentials it doesn't work, it says this:

"Oops. We came across some problems while setting up Vanilla...
Something bad happened when we were trying to create your administrative user account. Mysql said: Field 'Attributes' doesn't have a default value"

So I immediately tried changing my php settings, etc, which didn't seem to work, so I tried a manual install. That too didn't work and I ended up with a similar message, always to do with the Attributes table.

First I'll mention the manual installation fix that I made (not sure if it's the 'best' way to do it).

At the end of the topic "Note 3" mentions a way that I fixed the problem with the installer.

Manual Install Fix:
I simply changed the following (in the sql file):
INSERT INTO LUM_User (`RoleID`,`Name`,`Password`,`Email`,`FirstName`,`LastName`,`DateFirstVisit`,`DateLastActive`)
VALUES (6,'Admin',md5('Admin'),'[email protected]','Administrative','User','2005-06-22 00:00:00','2005-06-22 00:00:00');

to:
INSERT INTO LUM_User( `RoleID` , `Name` , `Password` , `Email` , `FirstName` , `LastName` , `DateFirstVisit` , `DateLastActive` , `Attributes`)
VALUES ( 6, 'Admin', md5( 'Admin' ) , '[email protected]', 'Administrative', 'User', '2005-06-22 00:00:00', '2005-06-22 00:00:00', ' ' ) ;

so that the attributes field would be blank by default, and register in the database. Did I miss something in the installation instructions prior to using the installer that would have fixed this easier?

Note: Using the Lussumo Vanilla (0.9.2.6) version.

Note 2: Also, I'm using MySQL 5.0.

Note 3: For the installer, the best fix seems to be the following:
Change:
`Attributes` text NOT NULL,
to:
`Attributes` text,

in the database.sql file under:
CREATE TABLE `LUM_User` (

Or is that "NOT NULL" important?

Comments

  • It's not so much that php5 isnt supported - in many cases it'l work but the code itself was written based on php4, so take that as you will. I've a feeling your error is likely due to using mysql 5 too. I've a feeling i hit that at some point and where mysql 4 was willing to take the NOT NULL instructions, mysql 5 would prefer it without them and thus wouldnt create the field (causing your initial error). Glad you got it working though :)
  • Thanks for the reply, mysql 5 being the culprit doesn't surprise me much. It seems most new software doesn't work with anything lately. lol.

    Now that you mention it, I really wish I hadn't gotten it to work, I know almost nothing about SQL so it took forever. Downgrading to version 4 would have been much faster. :/
  • i think i got the solution.Leastways my problem is solve.
    Open "C:/window/php.ini"
    Change the line following:
    ";extension=php_mysql.dll"
    to:
    " extension=php_mysql.dll"

    *.*
  • I'm running Vanilla 0.9.2.6 on Dreamhost with PHP 5.1.2 and MySQL5...but I didn't exactly *install* it on there. I actually installed and developed it (and the rest of the site) on a different host and moved it to the Dreamhost account later.

    That being said, I'm having no problems running it on the aforementioned setup after the migration.
  • Yeah, I got that same problem with MySQL 5. The thing is MySQL 5 runs in strict mode by default (unlike MySQL 4), so if you omit a column when inserting data, and the column is NOT NULL, and there is no default value, you're going to get an error.
This discussion has been closed.