Please upgrade here. These earlier versions are no longer being updated and have security issues.

ProxyConnect -- Fatal Error when integrating with Wordpress

When trying to configure a ProxyConnect Authenticator from the Vanilla dashboard, I get the following error message:

FATAL ERROR IN: Gdn_PluginManager.xAvailablePluginFolders();
The "Gdn_PluginManager" object does not have a "xAvailablePluginFolders" method." LOCATION: /home/content/j/p/m/jpmclaughlin/html/vanilla/library/core/class.pluggable.php
> 163: // Make sure that $ActualMethodName exists before continuing: > 164: if (!method_exists ... [the error info goes on for quite a while]

Here are the versions of everything I'm working with:
PHP 5.2.17
mySQL 5.0.77
Vanilla 2.0.17.10
Wordpress 3.1.3
ProxyConnect 1.9.7

I downloaded and embedded Vanilla into my Wordpress site with no problems. Vanilla is installed in the root of my domain (piercingproductions.com/vanilla/) and the site is a subdomain (demo.piercingproductions.com) with Wordpress install at root/demo/wp/.

I downloaded ProxyConnect and tried to get it set up. I uploaded "wordpress3-proxyconnect.php" from the "external" folder into the site's WP plugins, then uploaded the entire ProxyConnect folder into the "plugins" folder of my Vanilla installation. Both plugins show up and activate as expected.

However, then I get the fatal error when trying to configure the Authenticator.

Any ideas on what may be happening?

Comments

  • lucluc ✭✭
    Latest proxyconnect might need 2.0.18 beta.
  • Thanks for the tip. I tried upgrading to 2.0.18b2... while it fixed the Fatal Error, I can't find the "single sign-on" configuration page to copy/paste the info from the WP ProxyConnect plugin page.

    On a funny side note, now the sign in process for the embedded Forum is screwed up. I click one of the Sign In buttons and either nothing happens or it shows me as logged in but there isn't a link to the Vanilla dashboard. And since I had the "force URL" option selected in Vanilla, I keep getting redirected to my site... without the Dashboard link.

    I think I'll have to uninstall Vanilla and install the beta version from scratch. I'll post back if I still can't get it working.

    Fingers crossed.
  • Update: I started from scratch (several times)... I deleted all the Vanilla stuff, including the database, and reloaded Vanilla 2.0.18b2 and ProxyConnect 1.9.7.

    Within the Vanilla dashboard, I changed the User / Registration method from Basic (which I believe is the default) to Connect (which only registers users through the SSO plugin). Seems to have corrected the looping behavior when trying to sign in.

    Also, a good tip I found from other posts (which I guess should have been obvious to me) is to make sure to delete cookies from your browser(s) after you set everything up before you test.

Sign In or Register to comment.