Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.
Options

0.9.3 install problems

edited February 2006 in Vanilla 1.0 Help
OK, so I think I have done everything right. I SVN'd the files onto my local machine. applied the instructed changes to the files in conf/ created the database tables from the mysql.sql file in setup/ unfortunately when I then go to load the forum (ie: the index.php in the repository) the screen comes up blank. No errors, no picture, not text, no screw you, no kiss, no nothing. I experienced the same problem with 0.9.2 when I tried to alter the application settings. I dont know what I could be doing wrong. to check it out the URL is www.newlifecity.org/lifeinthecity/coffeeShop/ Any ideas?? Thanks all, Brad
«13

Comments

  • Options
    I have the same problem. I get a blank white screen also. Did you get the people and framework files from svn also? you need them. The Vanilla SVN files comes with people and framework. do I just replace these?
  • Options
    Nathan the vanilla SVN files will only come with people and framework if you checkout the files. Which it turns out you're not supposed to do. Though they will be the same files you'd get if you got people and framework seperately it's otherwise not good practice. As for the two of you getting blank screen problems i have no idea. I can only think that it's a server error because all the files are obviously there it's just the php inside them isnt getting executed. But assuming you use php elsewhere that doesnt really make sense. How very odd.
  • Options
    Ok, so I need clarification on this frameworks and people thing... when I did the SVN, I just got a SVN client for my mac, installed it and then followed the instructions on the update-info within vanilla. All I did was type SVN -co http://www.lussumo.com/vanilladev/trunk/ "my vanilla repository directory" or whatever the instructions were on the discussion here. When I did this it automatically grabbed frameworks and people. Is this bad?? if so then how do I not grab them?? Im wondering, does the -co in the command mean "check out", what other way should I get the files?? Im glad im not the only one having this issue though... Thanks all, Brad
  • Options
    lechlech Chicagoland
    I'm not sure what the nix equivalent is, but you should probably create a local folder for the repository (named anything) and use "update" instead of "check out" as the two have different uses. I kind of wish tortiseSVN was cross-platform to make everyones lives simpler. Perhaps it's time to hunt down some useful explorer shell-like driven clients, I think SVN info and details should be tossed up on the wiki since this appears to be a beast of interest lately. When I get some free time tonight, I'll compile a thorough as possible wiki page. Mark, think you could help out with the nix references for this one when you get a spare 20 minutes?
  • Options
    http://lussumo.com/community/discussion/1643/im-new-to-svn/#Item_3
  • Options
    lechlech Chicagoland
    ok, that works too, thanks Bergamot, that's simply for downloading a current SVN image without keeping it current via logs, .svn folders/files and updates, right? if you want to help post a further update example, I'll wrap it up later into a proper wiki page.
  • Options
    edited February 2006
    OK, so first of all I hate the hosting service im using for this site. They gave me this big runaround about not being able to view hidden files (dot files) essentially all the svn files... so I couldnt delete what I had on my server and start from scratch without them doing it for me :P bogus beyond belief. I wont be using them again thats for sure. Anyways, Im having more issues. I did a clean install of vanilla on my servers without the svn files (per Bergamots suggestion, thanks btw, much quicker and easier to manage). However my problem now lies in creating the database tables. When I run the mysql.sql file from my mysql management page it gives me an error when it runs. DROP TABLE `LUM_User` MySQL said: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'DROP TABLE `LUM_User`' at line 1 so this is weird... but when I run the query of the sqlite.sql file in the setup directory it seems to create all the tables correctly in my database, but when I try and view the forum, I get a blank screen. Any further ideas guys?? thanks all, Brad
  • Options
    Yeah, those chars before DROP will be confusing it. I think it's to do with the charset/encoding of the sql file, though i could be wrong. Try deleting them and then using the command again. As for using the sqlite file - i dont know the difference between mysql and sqlite so the chances are it might work just fine. But then we'd never be sure whether the blank screen was as a result of using sqlite commands into mysql and it getting confused somewhere or whether it's for a different reason (other people seem to be getting blank screens recently). Might be interesting to know whether they too used the sqlite file and what differences there actually are.
  • Options
    ok, after removing those characters from the beginning of the sql file It ran correctly and installed the tables as it should. Unfortunately that didnt fix the problem with the blank screen problem. Who all out there is having this problem too... Id like to compare setups and settings to see if we can nail this down
  • Options
    ok so I found an error log report through my server and I can see that I am definately getting errors, why they are not being reported to the screen is beyond me... anyways here are the errors I am getting in that log. http://www.newlifecity.org/lifeinthecity/coffeeShop/vanillaErrors.html This looks something like it could be permissions problems, but I think everything is right... All the files it says it cant find, are there... so I dontk now whats up. -Brad
  • Options
    edited February 2006
    Theyre not being sent to screen because all raw code errors are silenced with the intent that marks error logger will pick them up and report them more usefully. (though obviously not in this case) Can you show us what paths you have setup in the init_appg file?
  • Options
    um, I dont know of a init_appg file... though the paths I have setup in the /conf/settings.php file are this. $Configuration['APPLICATION_PATH'] = 'lifeinthecity/coffeeShop/'; $Configuration['DATABASE_PATH'] = $Configuration['APPLICATION_PATH'] . 'conf/database.php'; $Configuration['LIBRARY_PATH'] = $Configuration['APPLICATION_PATH'] . 'library/'; $Configuration['EXTENSIONS_PATH'] = $Configuration['APPLICATION_PATH'] . 'extensions/'; $Configuration['LANGUAGES_PATH'] = $Configuration['APPLICATION_PATH'] . 'languages/'; $Configuration['THEME_PATH'] = $Configuration['APPLICATION_PATH'] . 'themes/vanilla/'; // People Settings $Configuration['COOKIE_DOMAIN'] = '.newifecity.org'; $Configuration['COOKIE_PATH'] = '/'; $Configuration['SUPPORT_EMAIL'] = 'webmaster@newlifecity.org'; // Framework Settings $Configuration['DOMAIN'] = 'http://www.newlifecity.org/lifeinthecity/coffeeShop'; // Extension Configuration Parameters $Configuration['PERMISSION_DATABASE_CLEANUP'] = '0';
  • Options
    Yeah my bad. try changing Applicationpath to /hermes/web04/b1906/moo.newlif1/lifeinthecity/coffeeShop/
  • Options
    Ureka, sorta... ok now I see stuff... from what it looks like vanilla is working except it is completely unstylized. -Brad
  • Options
    lechlech Chicagoland
    dot files should be visible if you know how to uncover them via shell or via your ftp/ssh client. if you have a shell, just ls -al will give you a full listing of the dot files present in the directory you're in. Otherwise you ftp/ssh client you're using to transfer the files to your server should have an option to display/show those files (typically, the default setting is to hide them). If you're using TortiseSVN, the .svn folders and files are just hidden, you can go into your file and folder settings to unhide them.
  • Options
    hehe lech, you are spot on... Unfortunately I know about ls -al and ftp programs that will display them, this is what made the process so frusterating... however the jokers at the hosting service have eliminated that feature from use because of account securities or something contained in some root based dot files. So basicly, things should work, they have just limited me to not being able to. The ONLY way to view them is through a program called staff FTP which is Windows only compatible... me being on a mac really bites... luckely I have PC at home that I can use to do this, but its annoying. basicly its a really bad hosting service, and if it were up to me I would drop them... -Brad
  • Options
    another issue with the vanilla forum at this point is this... while the vanilla comes up unstyled if I click the link to go to discussions or catagories or whatever it tries to take me here: http://your.base.url/to/vanilla/ I found in the appg/settings.php this path listed as the base URL. though the document says that I shouldnt modify this document. Should I modify the path settings in the appg/settings.php file??? Thanks again guys, you ROCK!! -Brad
  • Options
    lechlech Chicagoland
    appg/settings.php is and should be modifyable, that's basically what stores more than half of your settings for vanilla to run in the first place. While What I don't understand is why your vanilla is coming up unstyled.
  • Options
    ok more progressions.... Once I went through the appg/settings.php file and customized it as appropriate the stylization and links all work. however when I try and login with admin admin to start messing with things it doesnt stay logged in ( or login at all) my guess is that it is a cookie issue? I also had this problem with 0.9.2, is this a continuation?? Thanks all, Brad
  • Options
    lechlech Chicagoland
    Cookies are still a bit akward in the 9.2.x versions, you might experience some having to login again and again. Unless you mean that if you logged in, and it doesn't show you logged in meaning you're not logged in, that could be a problem. If that made any sense at all.
This discussion has been closed.