Vanilla 1 is no longer supported or maintained. If you need a copy, you can get it here.
HackerOne users: Testing against this community violates our program's Terms of Service and will result in your bounty being denied.

Signature Mod

edited August 2006 in Vanilla 1.0 Help
i d/l the signature extension but it won't work does anyone know which mod is needed additionally? thank you


  • Options
    lechlech Chicagoland
    I would then answer your question with not one, but two questions of my own: What version of Vanilla, and which Version of said extension? :)
  • Options
    The modification needed is in the extension file, in a comment right under Mod:
  • Options
    do you know what is the comment needed
  • Options
    The directions are in a comment, ie. between /* and */. Follow those and it will tell you what files to edit and how.
  • Options
    thank you sirnot! thank you!!!!! still i get this! can someone help me!? Fatal error: Class declarations may not be nested in /home/ybalabin/public_html/community/library/Vanilla.Comment.class.php on line 613
  • Options
  • Options
    Dude this thread is half an hour old and was less than 10 slots down the main page, there's really no need to bump it.
  • Options
    NickENickE New
    edited February 2006
    Looks like you didn't modify the files correctly. Did you follow the following directions?
    [find in controls/comments.php]
    	$sReturn .= "</div>";
    $sReturn .= $PageList
    [replace first found line with]
    	$sReturn .= (strlen(isset($Comment->Settings['Signature']) ? $Comment->Settings['Signature'] : '') && defined('EXTENSION_SIGNATURE_ENABLED') ? ('<div class="Signature CommentTime" style="float: none; margin-top: 0; margin-bottom: 5px;">'.$Comment->Settings['Signature'].'</div>') : '')."</div>";
    [find in library/Vanilla.Comment.class.php, as well as in extensions/Whispers.php]
    	if ($this->AuthRoleIcon != "") $this->AuthIcon = $this->AuthRoleIcon;
    [add in the line above]
    	$this->Settings = UnserializeAssociativeArray(ForceString(@$DataSet['UserSettings'], ''));
    [find in those same files]
    	$s->AddWhere("m.DiscussionID", $DiscussionID, "=");
    	$s->AddOrderBy("DateCreated", "m", "asc");
    [add above]
    	if($this->Context->Session->User->Setting('AllowSignatures', 1) && defined('EXTENSION_SIGNATURE_ENABLED'))
    		$s->AddSelect('Settings', 'a', 'UserSettings');
  • Options
    Hold on, has the text changed in this thread or are my eyes going weird?
  • Options
    It has, I managed to make a really dumb mistake in the html formatter. I've fixed it but we're waiting for mark to update the site.
  • Options
    I'm sure it's better than anything I could've managed.
  • Options
    Sirnot thank you for answering my question and helping me put. unfortunately i tried it again as you told me (althouhg i didi the same things the first time) and this time whenever i try to enter a dicussion i get a totally blank page.... any ideas why this is happening? thank you
  • Options
    Coud you send me the files in question?
  • Options
    sure, where should i send them?
  • Options
  • Options
    I added this extension, added the modifications and I still don't see my signatures showing up. Any advice?
  • Options
    Are you sure you edited the files correctly? Were you attempting to use it with version 0.9.3? And, as stupid as this may sound, did you actually enter anything for you signature?
  • Options
    I edited the files correctly, I'm using the, and yes, I put something in the signature field and the signature box is checkmarked in the Forum Preferences.
  • Options
    Odd... You wouldn't happen to be using a custom theme or something, that might be hiding the signatures, would you? I don't recall any previous problems with this extension that didn't involve incorrect editing...
  • Options
    Nope, using the vanilla theme. It maybe because I'm currently having trouble enabling the extensions from the Manage Extensions. I had to manually add the Signatures extension in the extensions.php file.
This discussion has been closed.